php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49956 Issues with some procedural style mysqli functions
Submitted: 2009-10-22 13:15 UTC Modified: 2017-10-24 05:19 UTC
Votes:8
Avg. Score:3.6 ± 1.3
Reproduced:5 of 5 (100.0%)
Same Version:2 (40.0%)
Same OS:2 (40.0%)
From: wiesemann@php.net Assigned: levim (profile)
Status: Assigned Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2009-10-22 13:15 UTC] wiesemann@php.net
Description:
------------
While e.g. http://php.net/mysql_num_fields shows the documentation for mysql_num_fields(), this doesn't work for http://php.net/mysqli_num_fields (=> "Sorry, but the function mysqli_num_fields  is not in the online manual."). The reason seems to be that the OO-style name is mysqli_result->field_count. The redirection works for e.g. mysqli_num_rows() which OO-style is has the same scheme: mysqli_result->num_rows.

This is not only an issue with the php.net/functionname redirection, but also with the search field in the right upper corner of the website. Searching for "mysqli_num_fields" in the "function list" leads to the same error as described above. Searching in the "online documentation" works, though.

(There might be other examples than mysqli_*, of course.)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-03-05 21:12 UTC] levim@php.net
-Status: Open +Status: Verified -Assigned To: +Assigned To: levim
 [2015-05-24 23:03 UTC] levim@php.net
Automatic comment on behalf of levim
Revision: http://git.php.net/?p=web/php.git;a=commit;h=287cce470d5a84b9b56fbfaef472779671467ae9
Log: Partially fix bug #49956
 [2015-05-24 23:03 UTC] levim@php.net
-Status: Verified +Status: Closed
 [2015-05-24 23:07 UTC] levim@php.net
-Status: Closed +Status: Re-Opened
 [2015-05-24 23:07 UTC] levim@php.net
I have fixed mysqli_real_escape_string, mysqli_get_connection_stats and friends. However, the specific case mentioned here of mysqli_num_fields will not work yet. I am unsure how to tackle that particular one at this time. Perhaps we need a mysqli specific solution to handle the ones that go from mysqli to mysqli_result.
 [2015-08-08 17:40 UTC] dragoonis@php.net
Automatic comment on behalf of levim
Revision: http://git.php.net/?p=web/php.git;a=commit;h=73dc6a460736179528557f481711daef54ea5416
Log: Partially fix bug #49956
 [2015-08-08 17:40 UTC] dragoonis@php.net
-Status: Re-Opened +Status: Closed
 [2015-08-09 00:06 UTC] tyrael@php.net
Automatic comment on behalf of levim
Revision: http://git.php.net/?p=web/php.git;a=commit;h=287cce470d5a84b9b56fbfaef472779671467ae9
Log: Partially fix bug #49956
 [2015-08-27 19:55 UTC] asphp at dsgml dot com
This should not be closed, the bug is not fixed.
 [2015-08-27 20:39 UTC] cmb@php.net
-Status: Closed +Status: Re-Opened
 [2016-05-25 17:09 UTC] hellsing at index dot hu
This bug is already 6.5 years old and it still makes it harder to a procedural programmer to find documentation of mysqli functions.
 [2016-12-16 21:24 UTC] philip@php.net
A temporary mysqli specific fix was made for this, so it's moderately fixed. However, the root cause is not yet fixed.
 [2017-10-24 05:19 UTC] kalle@php.net
-Status: Re-Opened +Status: Assigned
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC