php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64683 PHP.net search doesn't find mysqli_num_fields().
Submitted: 2013-04-20 10:13 UTC Modified: 2014-11-28 20:12 UTC
Votes:5
Avg. Score:5.0 ± 0.0
Reproduced:5 of 5 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: smenjas at gmail dot com Assigned:
Status: Duplicate Package: Website problem
PHP Version: 5.4.14 OS: Ubuntu 12.04.2 LTS
Private report: No CVE-ID: None
 [2013-04-20 10:13 UTC] smenjas at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/mysqli-result.field-count#refsect1-mysqli-result.field-count-description
---

When searching php.net's function list for the function mysqli_num_fields(), the site improperly reports that "mysqli_num_fields doesn't exist."  The following URL says it does: http://www.php.net/mysqli-result.field-count


Expected result:
----------------
PHP.net should find functions that exist when I search for them.

Actual result:
--------------
PHP.net says "mysqli_num_fields doesn't exist."  It does.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-05-06 11:49 UTC] pete at petermcdonald dot co dot uk
This is confirmed. Both methods do not find this function (ie using the search and 
also using the url php.net/mysqli_num_fields )
 [2013-05-24 18:15 UTC] pete at petermcdonald dot co dot uk
Similar issue with the arrya_sort function as reported at 
https://bugs.php.net/bug.php?id=64743
 [2014-01-26 22:13 UTC] john dot w dot mcmahon at gmail dot com
Similar issue when searching for mysqli_free_result
Resulting search URL:
http://us1.php.net/manual-lookup.php?pattern=mysqli_free_result&scope=quickref
 [2014-06-08 16:32 UTC] sobak@php.net
-Type: Documentation Problem +Type: Bug -Package: Documentation problem +Package: Website problem
 [2014-11-28 20:12 UTC] sobak@php.net
-Status: Open +Status: Duplicate
 [2014-11-28 20:12 UTC] sobak@php.net
Duplicate of the bug #49956
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Mar 23 14:01:26 2019 UTC