php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #81229 mysqli_fetch_assoc not returned in PHP Manual search
Submitted: 2021-07-07 11:26 UTC Modified: 2021-07-07 12:09 UTC
From: Bruce dot Thompson at techco dot co dot uk Assigned: cmb (profile)
Status: Duplicate Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2021-07-07 11:26 UTC] Bruce dot Thompson at techco dot co dot uk
Description:
------------
"mysqli_fetch_assoc" not returned by PHP Manual search, although it can be found by browsing to the url:
https://www.php.net/manual/en/mysqli-result.fetch-assoc.php

Also seems to affect bug report searching too, as searching for this string finds nothing, but posting this report seems to find duplicates.

Test script:
---------------
1.	Search PHP Manual for “mysqli_fetch_assoc”

Returns:
2.	PHP Function List
mysqli_fetch_assoc doesn't exist. Closest matches: 
	•	mysql_fetch_assoc ...etc

Click on first one, gives:
3.	mysql_fetch_assoc
(PHP 4 >= 4.0.3, PHP 5)
mysql_fetch_assoc — Fetch a result row as an associative array
Warning
This extension was deprecated in PHP 5.5.0, and it was removed in PHP 7.0.0. Instead, the MySQLi or PDO_MySQL extension should be used. See also MySQL: choosing an API guide. Alternatives to this function include:
	•	mysqli_fetch_assoc()

Clicking on this option takes you to https://www.php.net/manual/en/mysqli-result.fetch-assoc.php:

4.	mysqli_result::fetch_assoc
mysqli_fetch_assoc
(PHP 5, PHP 7)...  ...etc
Copying mysqli_fetch_assoc and pasting it into PHP Manual search gives:

#2 and so Ad Infinitum



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-07-07 12:09 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Type: Documentation Problem +Type: Bug -Package: Documentation problem +Package: Website problem -Assigned To: +Assigned To: cmb
 [2021-07-07 12:09 UTC] cmb@php.net
Duplicate of bug #49956.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Sep 25 10:03:37 2021 UTC