php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77972 Many procedural-style mysqli_ functions that exist don't show up in search a...
Submitted: 2019-05-04 17:39 UTC Modified: 2019-05-04 17:43 UTC
From: php4fan at gmail dot com Assigned:
Status: Duplicate Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2019-05-04 17:39 UTC] php4fan at gmail dot com
Description:
------------
...utocomplete

Steps to reproduce:

1. Go to https://www.php.net/
2. In the search box, type "mysqli_free"

Expected result:
----------------
below the box, at least the result "mysqli_free_result" should show up as a suggestion, given that the function mysqli_free_result() exists.

Actual result:
--------------
It doesn't.

Yet if you write it completely on your own, it'll be found, because it does exist.

This doesn't happen with all mysqli_* functions, just some of them.

Pathetic as usual.

BTW there are a few similar reports that describe most probably related issues  with searching mysqli_* functions, but none of them clearly describe this specific issue, that is the one with the autocomplete.
So I'm reporting this as a separate bug, but feel free to merge. (please do fix it though, these issues have been known for years!)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-05-04 17:43 UTC] kalle@php.net
-Status: Open +Status: Duplicate
 [2019-05-04 17:43 UTC] kalle@php.net
Duplicate of bug #49956. You can add this information as a comment to the original bug, so who ever ends up solving this issue may use it as we do not have a merge reports feature.

Thank you
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Jul 21 10:01:26 2019 UTC