php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69463 Searching for mysqli_query returns "mysqli_query doesn't exist"
Submitted: 2015-04-15 14:00 UTC Modified: 2016-01-19 22:33 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: hr at herverenault dot fr Assigned: levim (profile)
Status: Closed Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2015-04-15 14:00 UTC] hr at herverenault dot fr
Description:
------------
Search for mysqli_query on php.net front page.

http://php.net/manual-lookup.php?pattern=mysqli_query&scope=quickref

PHP Function List

mysqli_query doesn't exist. Closest matches:

    mysql_query
    msql_query
    mssql_query
    ...

Then, on the mysql_query page, in the "Warning, deprecated" box, there is a link to http://php.net/manual/en/mysqli.query.php

Maybe this is some sort of revival from bug #50914. Not sure, though, because it is very old.

Expected result:
----------------
Search should return direct link to http://php.net/manual/en/mysqli.query.php



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-04-15 17:12 UTC] cmb@php.net
Related to bug #66340.
 [2016-01-19 22:08 UTC] phpjuju+phpbugs at gmail dot com
I reckon it is widely known that the searchability of php.net/<function> does not take into consideration any of the mysqli_* functions.  It seems like this would be a quick and easy fix.

Is there a way I contribute to this to make it work?  I'm not sure I understand where the documentation repo is in order to work on a patch.
 [2016-01-19 22:33 UTC] requinix@php.net
-Status: Open +Status: Closed -Type: Documentation Problem +Type: Bug -Package: Systems problem +Package: Website problem -Assigned To: +Assigned To: levim
 [2016-01-19 22:33 UTC] requinix@php.net
Marking this as complete due to
https://github.com/php/web-php/commit/287cce470d5a84b9b56fbfaef472779671467ae9

- http://php.net/mysqli_query
- http://php.net/manual-lookup.php?pattern=mysqli_query&scope=quickref
- "mysqli_query" in the search box
are all working fine for me. That even works for methods like PDO::query (using "pdo_query") which don't even have procedural forms.
 [2016-01-19 23:51 UTC] phpjuju+phpbugs at gmail dot com
http://php.net/mysqli_fetch_assoc
result: mysqli_fetch_assoc doesn't exist. Closest matches...

http://php.net/mysqli_fetch_row 
result: mysqli_fetch_row doesn't exist. Closest matches...
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Dec 14 13:01:24 2019 UTC