php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52345 make fails: glob_wrapper.c:40
Submitted: 2010-07-15 11:01 UTC Modified: 2013-12-05 19:42 UTC
From: dderbags at aol dot com Assigned:
Status: Duplicate Package: *General Issues
PHP Version: 5.3.2 OS: Solaris 10 x86
Private report: No CVE-ID:
 [2010-07-15 11:01 UTC] dderbags at aol dot com
Description:
------------
On Solaris 10 (11/09) x86, opensource packages from www.sunfreeware.com
Desired PHP-Version 5.3.2

Make fails with following error:
/bin/sh /data/build/php/532/php-5.3.2/libtool --silent --preserve-dup-deps --mode=compile gcc  -Imain/streams/ -I/data/build/php/532/php-5.3.2/main/streams/ -DPHP_ATOM_INC -I/data/build/php/532/php-5.3.2/include -I/data/build/php/532/php-5.3.2/main -I/data/build/php/532/php-5.3.2 -I/data/build/php/532/php-5.3.2/ext/date/lib -I/data/build/php/532/php-5.3.2/ext/ereg/regex -I/usr/local/include/libxml2 -I/usr/local/ssl/include -I/usr/local/include -I/usr/local/include/freetype2 -I/usr/local/imap-2007e/include -I/data/build/php/532/php-5.3.2/ext/mbstring/oniguruma -I/data/build/php/532/php-5.3.2/ext/mbstring/libmbfl -I/data/build/php/532/php-5.3.2/ext/mbstring/libmbfl/mbfl -I/usr/include/mysql -I/opt/oracle/client/rdbms/public -I/data/build/php/532/php-5.3.2/ext/sqlite3/libsqlite -I/usr/local/pgsql/include -I/data/build/php/532/php-5.3.2/TSRM -I/data/build/php/532/php-5.3.2/Zend  -D_POSIX_PTHREAD_SEMANTICS  -I/usr/local/include -g -O2   -c /data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c -o main/streams/glob_wrapper.lo
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c:40: Fehler: Syntaxfehler vor "glob_t"
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c:40: Warnung: kein Semikolon am Ende von »struct« oder »union«
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c:47: Fehler: Syntaxfehler vor »}«-Zeichen
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c:47: Warnung: Datendefinition hat keinen Typ oder Speicherklasse
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c: In function `_php_glob_stream_get_path':
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c:51: Fehler: »pglob« nicht deklariert (erste Benutzung in dieser Funktion)
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c:51: Fehler: (Jeder nicht deklarierte Bezeichner wird nur einmal aufgeführt
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c:51: Fehler: für jede Funktion in der er auftritt.)
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c:51: Fehler: Syntaxfehler vor »)«-Zeichen
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c: In function `_php_glob_stream_get_pattern':
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c:73: Fehler: »pglob« nicht deklariert (erste Benutzung in dieser Funktion)
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c:73: Fehler: Syntaxfehler vor »)«-Zeichen
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c: In function `_php_glob_stream_get_count':
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c:95: Fehler: »pglob« nicht deklariert (erste Benutzung in dieser Funktion)
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c:95: Fehler: Syntaxfehler vor »)«-Zeichen
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c: At top level:
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c:111: Fehler: Syntaxfehler vor »*«-Zeichen
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c: In function `php_glob_stream_path_split':
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c:124: Fehler: »p_file« nicht deklariert (erste Benutzung in dieser Funktion)
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c:126: Fehler: »get_path« nicht deklariert (erste Benutzung in dieser Funktion)
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c:127: Fehler: »pglob« nicht deklariert (erste Benutzung in dieser Funktion)
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c: In function `php_glob_stream_read':
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c:141: Fehler: »pglob« nicht deklariert (erste Benutzung in dieser Funktion)
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c:141: Fehler: Syntaxfehler vor »)«-Zeichen
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c:148: Fehler: »GLOB_APPEND« nicht deklariert (erste Benutzung in dieser Funktion)
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c: In function `php_glob_stream_close':
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c:165: Fehler: »pglob« nicht deklariert (erste Benutzung in dieser Funktion)
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c:165: Fehler: Syntaxfehler vor »)«-Zeichen
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c: In function `php_glob_stream_rewind':
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c:184: Fehler: »pglob« nicht deklariert (erste Benutzung in dieser Funktion)
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c:184: Fehler: Syntaxfehler vor »)«-Zeichen
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c: In function `php_glob_stream_opener':
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c:211: Fehler: »pglob« nicht deklariert (erste Benutzung in dieser Funktion)
/data/build/php/532/php-5.3.2/main/streams/glob_wrapper.c:251: Fehler: »GLOB_APPEND« nicht deklariert (erste Benutzung in dieser Funktion)
make: *** [main/streams/glob_wrapper.lo] Error 1

My configure-scrit reads:
#!/bin/sh
#
/data/build/php/532/php-5.3.2/configure \
--prefix=/usr/local/php-5.2.3 \
--enable-bcmath \
--enable-calendar \
--enable-exif \
--enable-ftp \
--enable-gd-native-ttf \
--enable-magic-quotes \
--enable-mbstring \
--enable-safe-mode \
--enable-shmop \
--enable-sigchild \
--enable-sysvsem \
--enable-sysvshm \
--enable-wddx \
--with-bz2 \
--with-libxml-dir=/usr/local \
--with-gettext=/usr/local \
--with-jpeg-dir=/usr/local \
--with-ldap \
--with-mysql \
--with-ndbm \
--with-iconv-dir=/usr/local \
--with-pgsql=/usr/local/pgsql \
--with-png-dir=/usr/local \
--with-freetype-dir=/usr/local \
--with-xpm-dir=/usr/local \
--with-zlib=/usr/local \
--with-gd=/usr/local \
--with-openssl=/usr/local/ssl \
--with-imap=/usr/local/imap-2007e \
--with-imap-ssl=/usr/local/ssl \
--with-pear \
--with-oci8=/opt/oracle/client \
--with-apxs2=/usr/local/apache2/bin/apxs

IMAP compiled as described here: http://de3.php.net/manual/de/imap.requirements.php

Oracle Client version: 11.2.0.1.0

Thanks for helping!


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-07-15 12:36 UTC] christian dot schaffer at muenchen dot de
Additional comment:
PHP 5.2.13 make runs successfully with same configuration.
 [2010-07-16 05:58 UTC] aharvey@php.net
-Status: Open +Status: Duplicate
 [2010-07-16 05:58 UTC] aharvey@php.net
Duplicate of bug #49301.

Bug #51974 (which was also a dupe of #49301) has the compilation errors
in English, for other people like me who aren't particularly fluent in
German. :)
 [2013-12-05 19:42 UTC] mike@php.net
-Status: Open +Status: Duplicate
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 24 02:02:10 2014 UTC