php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51974 make: Fatal error: Command failed for target `main/streams/glob_wrapper.lo'
Submitted: 2010-06-02 14:45 UTC Modified: 2010-06-02 23:38 UTC
From: pooya_4075 at yahoo dot de Assigned:
Status: Not a bug Package: Compile Failure
PHP Version: 5.3.2 OS: Solaris 5.10
Private report: No CVE-ID:
 [2010-06-02 14:45 UTC] pooya_4075 at yahoo dot de
Description:
------------
Hello,

i'm installing the php-5.3.2 on sun/sjsws system as FastCgi.

·         Operating System: Solaris  5.10

·         WebServer  SJSWS 7.0 listening to the standard port : 80

·         Oracle- Client:  11.2.0

gcc version 3.4.3 (csl-sol210-3_4-branch+sol_rpath)

my configure: ./configure --prefix=$PHP_HOME --with-oci8=$ORACLE_HOME --with-pear=$PHP_HOME --enable-calendar --with-zlib --with-gd --with-png-dir=/usr/lib --enable-libgcc --enable-zip --with-gettext

Seems ok, but the make results the following error:

*** Error code 1
make: Fatal error: Command failed for target `main/streams/glob_wrapper.lo'


What can be wrong? would you please help me?

Best regards


Actual result:
--------------
-I/tmp/php-5.3.2/Zend  -D_POSIX_PTHREAD_SEMANTICS  -I/usr/local/include -g -O2  -c /tmp/php-5.3.2/main/streams/glob_wrapper.c -o main/streams/glob_wrapper.lo
/tmp/php-5.3.2/main/streams/glob_wrapper.c:40: error: syntax error before "glob_t"
/tmp/php-5.3.2/main/streams/glob_wrapper.c:40: warning: no semicolon at end of struct or union
/tmp/php-5.3.2/main/streams/glob_wrapper.c:47: error: syntax error before '}' token
/tmp/php-5.3.2/main/streams/glob_wrapper.c:47: warning: data definition has no type or storage class
/tmp/php-5.3.2/main/streams/glob_wrapper.c: In function `_php_glob_stream_get_path':
/tmp/php-5.3.2/main/streams/glob_wrapper.c:51: error: `pglob' undeclared (first use in this function)
/tmp/php-5.3.2/main/streams/glob_wrapper.c:51: error: (Each undeclared identifier is reported only once
/tmp/php-5.3.2/main/streams/glob_wrapper.c:51: error: for each function it appears in.)
/tmp/php-5.3.2/main/streams/glob_wrapper.c:51: error: syntax error before ')' token
/tmp/php-5.3.2/main/streams/glob_wrapper.c: In function `_php_glob_stream_get_pattern':
/tmp/php-5.3.2/main/streams/glob_wrapper.c:73: error: `pglob' undeclared (first use in this function)
/tmp/php-5.3.2/main/streams/glob_wrapper.c:73: error: syntax error before ')' token
/tmp/php-5.3.2/main/streams/glob_wrapper.c: In function `_php_glob_stream_get_count':
/tmp/php-5.3.2/main/streams/glob_wrapper.c:95: error: `pglob' undeclared (first use in this function)
/tmp/php-5.3.2/main/streams/glob_wrapper.c:95: error: syntax error before ')' token
/tmp/php-5.3.2/main/streams/glob_wrapper.c: At top level:
/tmp/php-5.3.2/main/streams/glob_wrapper.c:111: error: syntax error before '*' token
/tmp/php-5.3.2/main/streams/glob_wrapper.c: In function `php_glob_stream_path_split':
/tmp/php-5.3.2/main/streams/glob_wrapper.c:124: error: `p_file' undeclared (first use in this function)
/tmp/php-5.3.2/main/streams/glob_wrapper.c:126: error: `get_path' undeclared (first use in this function)
/tmp/php-5.3.2/main/streams/glob_wrapper.c:127: error: `pglob' undeclared (first use in this function)
/tmp/php-5.3.2/main/streams/glob_wrapper.c: In function `php_glob_stream_read':
/tmp/php-5.3.2/main/streams/glob_wrapper.c:141: error: `pglob' undeclared (first use in this function)
/tmp/php-5.3.2/main/streams/glob_wrapper.c:141: error: syntax error before ')' token
/tmp/php-5.3.2/main/streams/glob_wrapper.c:148: error: `GLOB_APPEND' undeclared (first use in this function)
/tmp/php-5.3.2/main/streams/glob_wrapper.c: In function `php_glob_stream_close':
/tmp/php-5.3.2/main/streams/glob_wrapper.c:165: error: `pglob' undeclared (first use in this function)
/tmp/php-5.3.2/main/streams/glob_wrapper.c:165: error: syntax error before ')' token
/tmp/php-5.3.2/main/streams/glob_wrapper.c: In function `php_glob_stream_rewind':
/tmp/php-5.3.2/main/streams/glob_wrapper.c:184: error: `pglob' undeclared (first use in this function)
/tmp/php-5.3.2/main/streams/glob_wrapper.c:184: error: syntax error before ')' token
/tmp/php-5.3.2/main/streams/glob_wrapper.c: In function `php_glob_stream_opener':
/tmp/php-5.3.2/main/streams/glob_wrapper.c:211: error: `pglob' undeclared (first use in this function)
/tmp/php-5.3.2/main/streams/glob_wrapper.c:251: error: `GLOB_APPEND' undeclared (first use in this function)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-06-02 15:01 UTC] pooya_4075 at yahoo dot de
-Summary: Fatal error: +Summary: make: Fatal error: Command failed for target `main/streams/glob_wrapper.lo' -Package: *Compile Issues +Package: Compile Failure
 [2010-06-02 15:01 UTC] pooya_4075 at yahoo dot de
main/streams/glob_wrapper.c
 [2010-06-02 23:38 UTC] felipe@php.net
-Status: Open +Status: Bogus
 [2010-06-02 23:38 UTC] felipe@php.net
Duplicate of bug #49301
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Mon Apr 21 00:02:04 2014 UTC