php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49301 HAVE_GLOB is not detected correctly
Submitted: 2009-08-19 20:46 UTC Modified: 2010-09-11 17:58 UTC
Votes:3
Avg. Score:3.0 ± 0.0
Reproduced:3 of 3 (100.0%)
Same Version:3 (100.0%)
Same OS:2 (66.7%)
From: php at stefan-marr dot de Assigned: felipe
Status: Closed Package: Compile Failure
PHP Version: 5.3.x OS: Mac OS X 10.6, Solaris 5.10
Private report: No CVE-ID:
 [2009-08-19 20:46 UTC] php at stefan-marr dot de
Description:
------------
Seems like HAVE_GLOB is not set correctly by I guess configure.
It is needed to be set in main/streams/glob_wrapper.c to be able to 
compile


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-11-17 10:04 UTC] dsp@php.net
Please try using this snapshot:

  http://snaps.php.net/php6.0-latest.tar.gz
 
For Windows:

  http://windows.php.net/snapshots/


 [2009-11-25 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2010-06-02 23:39 UTC] felipe@php.net
-Status: No Feedback +Status: Open -Operating System: Mac OS X 10.6 +Operating System: Mac OS X 10.6, Solaris 5.10 -PHP Version: 6SVN-2009-08-19 (SVN) +PHP Version: 5.3.x
 [2010-06-07 13:56 UTC] pooya_4075 at yahoo dot de
the snapshot http://snaps.php.net/php6.0-latest.tar.gz dont exists...

I tried other snapshots like php5.3-latest with the same result(Make: Fatal error: Command failed for target `main/streams/glob_wrapper.lo') !!!

Is there any other solution?

thanks
 [2010-07-16 08:34 UTC] christian dot schaffer at muenchen dot de
#51974 http://bugs.php.net/bug.php?id=51974
#52345 http://bugs.php.net/bug.php?id=52345

Is this problem likely to be solved in the near future?
 [2010-07-16 08:43 UTC] rasmus@php.net
Just to clarify, this is a Solaris-only problem?  The OS field says OSX 10.6 as 
well and I am unable to reproduce the problem there.  My HAVE_GLOB is picked up 
nicely and glob() works perfectly for me on OSX 10.6.4.
 [2010-08-03 23:40 UTC] bogdan at trzebnica dot net
I try compile php5.3.3....I have the same problem on debian lenny 2.6.26-2-amd64...On Debian 2.6.26-2-686 I can compile without problem...What is wrong ? Help pls!
 [2010-08-06 00:13 UTC] lamont dot peterson at imail dot org
I'm building php-5.3.3 on Solaris 10 (5.10) on UltraSPARC T2 (Sun T2000) systems.  I have working builds and then ran into this (configure?) bug when I added "--with-iodbc" to the list of configure options.  Here's the rest of my list of configure options:

'./configure' \
'--prefix=/usr/share' \
'--datadir=/usr/share/php' \
'--bindir=/usr/bin' \
'--libdir=/usr/share' \
'--includedir=/usr/include' \
'--with-config-file-path=/etc' \
'--with-exec-dir=/usr/lib/php/bin' \
'--disable-debug' \
'--enable-bcmath' \
'--enable-calendar' \
'--enable-ctype' \
'--enable-exif' \
'--enable-gd-native-ttf' \
'--enable-inline-optimization' \
'--enable-magic-quotes' \
'--enable-mbstring' \
'--enable-safe-mode' \
'--enable-shmop' \
'--enable-sigchild' \
'--enable-sysvsem' \
'--enable-sysvshm' \
'--enable-wddx' \
'--with-bz2' \
'--with-gdbm' \
'--with-gettext' \
'--with-gmp' \
'--with-jpeg-dir=/usr' \
'--with-ldap=yes' \
'--with-mcrypt' \
'--with-ndbm' \
'--with-pgsql=/usr' \
'--with-png-dir=/usr' \
'--with-t1lib' \
'--with-freetype-dir=yes' \
'--with-xpm-dir=/usr/X11R6' \
'--with-zlib=yes' \
'--with-gd=shared' \
'--with-openssl=/usr/local/ssl' \
'--with-curl' \
'--with-apxs2=/usr/local/bin/apxs'

If you add "--with-iodbc" to that list, it fails and I see the same output as found in #51974 (marked as duplicate of this one).  I built and installed libiodbc-3.52.7, only using the --disable-gui and --disable-gtktest configure options.

I also tried this with php-5.3.2 and saw the same problem.
 [2010-09-11 17:58 UTC] felipe@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: felipe
 [2010-09-11 17:58 UTC] felipe@php.net
The bug has been fixed, please try a snapshot.
 [2010-09-17 19:38 UTC] jeff dot clemmer at us dot army dot mil
I too, have encountered the same exact compilation failure as the earlier posters and hope that this bug is soon addressed by a new production release.  I am using Solaris 5.10 with the following compilation: 

./configure \
--prefix=/opt/php \
--enable-sigchild \
--enable-calendar \
--with-mysql=/opt/mysql \
--with-config-file-path=/opt/apache/conf \
--with-libxml-dir=/usr/local \
--with-zlib-dir/usr/local \
--with-iconv-dir=/usr/local \
--with-oci8=/appl/oracle_client10 \
--enable-soap \
--with-openssl=/opt/openssl \
--qith-apxs2=/opt/apache/bin/apxs \
--with-curl=/opt/curl \
--with-curlwrappers \
--enable-mbstring \
--with-mcrypt=/opt/libmcrypt
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 10:03:03 2014 UTC