php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8745 --with-zlib and --with-sablot will compile seperately but not together
Submitted: 2001-01-16 15:17 UTC Modified: 2001-01-16 15:24 UTC
From: lbergman at abi dot tconline dot net Assigned:
Status: Closed Package: Sablotron XSL
PHP Version: 4.0.4pl1 OS: RH6.2 - 2.2.12-20smp
Private report: No CVE-ID: None
 [2001-01-16 15:17 UTC] lbergman at abi dot tconline dot net
reproduce -
compile sablot and zlib together, in any order
see bug #8603 for this same problem but with 4.0.4
That bug was fixed in the snaps as of 2000101151145. I don't know what the pl1 was based on so I thought I would go ahead and submit this. Hope it's not to much of a bother. And as always, thanks for the great tool.

============
debug.log
============
CONFIGURE:   './configure' '--with-apxs=/usr/sbin/apxs' '--enable-track-vars' '--enable-trans-sid' '--disable-debug' '--with-zlib=/usr/local/lib' '--with-sablot=/usr/local/lib'
CC:         gcc
CFLAGS:     -g -O2
CPPFLAGS:    -DLINUX=2 -DEAPI -DUSE_EXPAT
CXX:        
CXXFLAGS:   
INCLUDES:    -I/usr/include/apache  -I$(top_builddir)/Zend -I/root/tar/php-4.0.4pl1/ext/mysql/libmysql -I/usr/local/include
LDFLAGS:     -Wl,-rpath,/usr/local/lib -L/usr/local/lib
LIBS:       -lxmltok -lxmlparse -lsablot -lresolv -lm -ldl -lcrypt -lnsl  -lresolv
DLIBS:      
SAPI:       apache
PHP_RPATHS:  /usr/local/lib
uname -a:   Linux ns1.abi.tconline.net 2.2.12-20smp #1 SMP Mon Sep 27 10:34:45 EDT 1999 i686 unknown

gcc -o conftest -g -O2  -DLINUX=2 -DEAPI -DUSE_EXPAT  -Wl,-rpath,/usr/local/lib -L/usr/local/lib conftest.c -lxmltok -lxmlparse -lsablot -lresolv -lm -ldl -lcrypt -lnsl  -lresolv 1>&5
/usr/local/lib/libsablot.so: undefined reference to `XML_ParserCreateNS'
/usr/local/lib/libsablot.so: undefined reference to `XML_SetCommentHandler'
/usr/local/lib/libsablot.so: undefined reference to `XML_SetNamespaceDeclHandler'
collect2: ld returned 1 exit status

=================
config.log
=================

#if BYTE_ORDER != BIG_ENDIAN
 not big endian
#endif
; return 0; }
configure:42680: checking for XML support
configure:43091: checking for YAZ support
configure:43441: checking whether to include YP support
configure:43638: checking whether to include zlib support
configure:43839: checking for gzgets in -lz
configure:43858: gcc -o conftest -g -O2  -DLINUX=2 -DEAPI -DUSE_EXPAT -DXML_BYTE_ORDER=12 -L/usr/lib  -Wl,-rpath,/usr/local/lib -L/usr/local/lib conftest.c -lz  -lxmltok -lxmlparse -lsablot -lresolv -lm -ldl -lcrypt -lnsl  -lresolv 1>&5
/usr/local/lib/libsablot.so: undefined reference to `XML_ParserCreateNS'
/usr/local/lib/libsablot.so: undefined reference to `XML_SetCommentHandler'
/usr/local/lib/libsablot.so: undefined reference to `XML_SetNamespaceDeclHandler'
collect2: ld returned 1 exit status
configure: failed program was:
#line 43847 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char gzgets();

int main() {
gzgets()
; return 0; }

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-16 15:24 UTC] derick@php.net
Try if the following works for you:
1) go to /ext/sablot
2) replace the ADD_LIBRARY(xmltok) and ADD_LIBRARY(xmlparse) in config.m4 to ADD_LIBRARY(expat)
3) go to the php source root
4) run ./buildconf
5) do a make clean, rm config.log and try building from start

You ca also try the latest snapshot from snaps.php.net because this should be fixed in the CVS
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jul 05 15:01:27 2020 UTC