php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8603 zlib and xslt seem incompatible on this system
Submitted: 2001-01-08 18:27 UTC Modified: 2001-01-11 11:55 UTC
From: lbergman at abi dot tconline dot net Assigned:
Status: Closed Package: Sablotron XSL
PHP Version: 4.0.4 OS: RH6.1 linux kernel 2.2.12-20 smp
Private report: No CVE-ID: None
 [2001-01-08 18:27 UTC] lbergman at abi dot tconline dot net
Reproduce: Compile flags --with-zlib --with-sablot
Configure line:
./configure \
--enable-track-vars \
--enable-trans-sid \
--disable-debug \
--with-zlib=/usr/local/lib \
--with-sablot=/usr/local/lib
php.ini not relevant
gdb backtrace: Not a php crash

Description:
On this system if zlib and sablot are configured together the configure always fails with this error:
"Zlib module requires zlib >= 1.0.9."
The prior build phpinfo() reports zlib enabled with a version of 1.1.3 and I found no problems with it. Just to make sure I compiled zlib again from the source and got the same error. Either zlib or sablot will configure and make seperately but not together and not in any order. I tried the sablot linux binary w/o the expat from sourceforge. With the expat. Compiling the source from sablot with the expat. All bailed at the same place when compiled with zlib and all but the binary worked without it.

I have seen mention on the list of configures with the above that have not had this problem. Is this a known compiler issue? 
P.S. First time to try compiling sablot.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-08 18:29 UTC] lbergman at abi dot tconline dot net
The configure line did not include --with-apxs which it shaould have.
 [2001-01-08 18:38 UTC] derick@php.net
Can you paste the appropriate piece of config.log into this bugreport?
 [2001-01-08 19:15 UTC] lbergman at abi dot tconline dot net
debug.log
CONFIGURE:   './configure' '--with-apxs=/usr/sbin/apxs' '--enable-track-vars' '--enable-trans-sid' '--disable-debug' '--with-zlib=/usr/local/lib' '--with-sablot=/usr/local/lib'
CC:         gcc
CFLAGS:     -g -O2
CPPFLAGS:    -DLINUX=2 -DEAPI -DUSE_EXPAT
CXX:        
CXXFLAGS:   
INCLUDES:    -I/usr/include/apache  -I$(top_builddir)/Zend -I/root/tar/php-4.0.4/ext/mysql/libmysql -I/usr/local/include
LDFLAGS:     -Wl,-rpath,/usr/local/lib -L/usr/local/lib
LIBS:       -lxmltok -lxmlparse -lsablot -lresolv -lm -ldl -lcrypt -lnsl  -lresolv
DLIBS:      
SAPI:       apache
PHP_RPATHS:  /usr/local/lib
uname -a:   Linux ns1.abi.tconline.net 2.2.12-20smp #1 SMP Mon Sep 27 10:34:45 EDT 1999 i686 unknown

gcc -o conftest -g -O2  -DLINUX=2 -DEAPI -DUSE_EXPAT  -Wl,-rpath,/usr/local/lib -L/usr/local/lib conftest.c -lxmltok -lxmlparse -lsablot -lresolv -lm -ldl -lcrypt -lnsl  -lresolv 1>&5
/usr/local/lib/libsablot.so: undefined reference to `XML_ParserCreateNS'
/usr/local/lib/libsablot.so: undefined reference to `XML_SetCommentHandler'
/usr/local/lib/libsablot.so: undefined reference to `XML_SetNamespaceDeclHandler'
collect2: ld returned 1 exit status
---------------------------------------------------
---------------------------------------------------
I hope this is the part you want from config.log
If not let me know and I will post the rest, or rerun w/o one of the two to see the difference. Just let me know what I can do to help. Thanks.

#if BYTE_ORDER != BIG_ENDIAN
 not big endian
#endif
; return 0; }
configure:42676: checking for XML support
configure:43087: checking for YAZ support
configure:43437: checking whether to include YP support
configure:43634: checking whether to include zlib support
configure:43835: checking for gzgets in -lz
configure:43854: gcc -o conftest -g -O2  -DLINUX=2 -DEAPI -DUSE_EXPAT -DXML_BYTE_ORDER=12 -L/usr/lib  -Wl,-rpath,/usr/local/lib -L/usr/local/lib conftest.c -lz  -lxmltok -lxmlparse -lsablot -lresolv -lm -ldl -lcrypt -lnsl  -lresolv 1>&5
/usr/local/lib/libsablot.so: undefined reference to `XML_ParserCreateNS'
/usr/local/lib/libsablot.so: undefined reference to `XML_SetCommentHandler'
/usr/local/lib/libsablot.so: undefined reference to `XML_SetNamespaceDeclHandler'
collect2: ld returned 1 exit status
configure: failed program was:
#line 43843 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char gzgets();

int main() {
gzgets()
; return 0; }

 [2001-01-11 11:55 UTC] sniper@php.net
Please try the latest CVS snapshot from http://snaps.php.net/ as this should be fixed now.

And if your sablot version is 0.50 you need to have
the external expat libarary installed in your system.

Then you have to use --with-expat-dir=/path/to/expat/install
in your configure line.

Reopen this bug report if this doesn't work.

--Jani
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jul 11 18:01:24 2020 UTC