php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77398 print_r($GLOBALS) causes memory limit to exceed
Submitted: 2019-01-02 11:39 UTC Modified: 2019-01-02 11:45 UTC
From: php at xanady dot de Assigned:
Status: Duplicate Package: *General Issues
PHP Version: 7.3.0 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: php at xanady dot de
New email:
PHP Version: OS:

 

 [2019-01-02 11:39 UTC] php at xanady dot de
Description:
------------
Any usage of print_r($GLOBALS) in PHP 7.3 results in an fatal error:

Fatal error: Allowed memory size of 1073741824 bytes exhausted (tried to allocate 534777856 bytes) in /............./test.php on line 2

Works fine in other php versions.

See here: https://3v4l.org/AdLgJ

Test script:
---------------
<?php

print_r($GLOBALS);

?>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-01-02 11:45 UTC] spam2 at rhsoft dot net
you are late to the party
https://bugs.php.net/bug.php?id=77387
 [2019-01-02 11:45 UTC] nikic@php.net
-Status: Open +Status: Duplicate
 [2019-01-02 11:45 UTC] nikic@php.net
Duplicate of bug #77387, which has been fixed earlier today :)
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Apr 10 12:01:23 2021 UTC