php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77013 MySQLnd: auth_plugin_caching_sha2_password is missing again
Submitted: 2018-10-15 14:16 UTC Modified: 2018-10-15 17:20 UTC
From: ademybiz at gmail dot com Assigned: cmb (profile)
Status: Duplicate Package: MySQL related
PHP Version: 7.2.11 OS: CentOS7(Dockerized)
Private report: No CVE-ID: None
 [2018-10-15 14:16 UTC] ademybiz at gmail dot com
Description:
------------
I maintain my own docker image and recently update for 7.2.9 to 11 then it fails to connect a MySQL8 server.

Found difference of loaded plugins of MySQLnd, see below, "auth_plugin_caching_sha2_password" is missing.

Test script:
---------------
./configure --prefix=/usr --with-config-file-path=/usr/etc --with-mysqli=mysqlnd --with-pdo-mysql=mysqlnd --with-iconv-dir=/usr/local --with-freetype-dir --with-jpeg-dir --with-png-dir --with-zlib --with-libxml-dir=/usr --enable-xml --disable-rpath --enable-bcmath --enable-shmop --enable-sysvsem --enable-sysvshm --enable-inline-optimization --with-curl=/usr --enable-mbregex --enable-fpm --enable-mbstring --with-gd --with-openssl --enable-pcntl --enable-sockets --with-xmlrpc --with-libzip --enable-soap --with-bz2 --with-gmp --with-gettext --with-readline --enable-sockets --enable-calendar --enable-opcache --with-sodium
(...build it)
php -i|grep "Loaded plugins"

Expected result:
----------------
Loaded plugins => mysqlnd,debug_trace,auth_plugin_mysql_native_password,auth_plugin_mysql_clear_password,auth_plugin_caching_sha2_password,auth_plugin_sha256_password

Actual result:
--------------
Loaded plugins => mysqlnd,debug_trace,auth_plugin_mysql_native_password,auth_plugin_mysql_clear_password,auth_plugin_sha256_password

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-10-15 17:20 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2018-10-15 17:20 UTC] cmb@php.net
Duplicate of request #76243.
 [2018-11-08 11:36 UTC] likeboat at 163 dot com
same as php 7.2.12, any plan to fix it ?

thanks,
Billy
 [2019-01-22 17:07 UTC] virgofx at live dot com
Any updated on when caching_sha2_password PR can get merged? Also missing in the 7.3.x releases.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Aug 20 19:01:29 2019 UTC