php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75492 Massive memory allocation
Submitted: 2017-11-06 22:41 UTC Modified: 2018-06-24 04:25 UTC
From: nick at nickstallman dot net Assigned:
Status: No Feedback Package: FPM related
PHP Version: 7.1.11 OS: Ubuntu
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2017-11-06 22:41 UTC] nick at nickstallman dot net
Description:
------------
I just had the following error which is so ridiculous it's not funny:


Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 5826880341616844800 bytes) in ...snip.../application/views/dns/view.php on line 4
�@Error
Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 139817084080128 bytes) in ...snip.../application/views/errors/html/error_php.php on line 9

This is a CodeIgniter app, and line 4 of view.php is a echo of a single quoted string with no variables at all.

The server config is PHP-FPM with the Ubuntu package from the ondrej PPA 1:7.1+55+ubuntu16.04.1+deb.sury.org+1

It might just be a random glitch, but I certainly found it very surprising.

Test script:
---------------
I'm having a little bit of trouble reproducing the issue, and as the error line is about an echo I have no clue what test script would cause it.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-11-06 22:51 UTC] danack@php.net
-Status: Open +Status: Feedback
 [2017-11-06 22:51 UTC] danack@php.net
HI Nick,

Please could you list the modules loaded by running `php -m`

Also, please could you generate a backtrace with the instructions from https://bugs.php.net/bugs-generating-backtrace.php
 [2017-11-06 23:21 UTC] nick at nickstallman dot net
Unfortunately I can't seem to reproduce it to get a backtrace.

PHP modules are here: https://gist.github.com/NickStallman/f271375225a99918bd72ebfacdb58cdc
Nothing too unusual. The opcache is enabled.
 [2017-11-07 19:53 UTC] adambaratz@php.net
When I ran into an issue like this, it was a result of an extension writing to memory that it shouldn't have. Basically, the value for a string length got corrupted and then this happened. Unless you're really comfortable with gdb, my general suggestion would be to try disabling non-core extensions to try to narrow it down. You could also try disabling the PCRE JIT.
 [2018-06-24 04:25 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sat Sep 22 09:01:25 2018 UTC