php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #73733 win32service does not compile on Windows for PHP7.0
Submitted: 2016-12-13 10:34 UTC Modified: 2017-05-02 14:17 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: michael dot mckeever at bosch dot com Assigned: rquadling (profile)
Status: Closed Package: win32service (PECL)
PHP Version: 7.0.14 OS: Windows all versions
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: michael dot mckeever at bosch dot com
New email:
PHP Version: OS:

 

 [2016-12-13 10:34 UTC] michael dot mckeever at bosch dot com
Description:
------------
Hi,

the package does not compile for PHP 7.0.14 (x64) VC14

The configuration:
configure --disable-all --enable-cli --enable-win32service=shared

The error says:
   Creating library C:\php-sdk\phpdev\vc14\x64\php-7.0.14-src\x64\Release_TS\php_win32service.lib and object C:\php-sdk\phpdev\vc14\x64\php-7.0.14-src\x64\Release_TS\php_win32service.exp
win32service.obj : error LNK2019: unresolved external symbol Z_TYPE_PP referenced in function svc_thread_proc
win32service.obj : error LNK2019: unresolved external symbol Z_STRVAL_PP referenced in function svc_thread_proc
win32service.obj : error LNK2019: unresolved external symbol Z_STRLEN_PP referenced in function svc_thread_proc
win32service.obj : error LNK2019: unresolved external symbol Z_LVAL_PP referenced in function svc_thread_proc
C:\php-sdk\phpdev\vc14\x64\php-7.0.14-src\x64\Release_TS\php_win32service.dll : fatal error LNK1120: 4 unresolved externals
NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\BIN\amd64\link.exe"' : return code '0x460'
Stop.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-12-13 10:42 UTC] cmb@php.net
-Assigned To: +Assigned To: rquadling
 [2016-12-13 10:42 UTC] cmb@php.net
Richard, is PECL/win32service still maintained?
 [2016-12-14 12:06 UTC] rquadling@php.net
Hi.

I'm no longer on a Windows platform and I don't have any licenses for anything other than a Windows XP. As such, without a licence for whichever version of Windows we need to support for win32service, I am unable to provide any further development on this extension.

If I was to get a license, I'd be using OSX+VirtualBox. I have no other hardware.

Is there any chance that Zend could sponsor some Windows based AWS instances for builds? Or something similar?
 [2016-12-14 16:08 UTC] cmb@php.net
> Is there any chance that Zend could sponsor some Windows based AWS instances for builds? Or something similar?

I don't know, but I suggest you ask on the internals and/or the internals-win mailing list.
 [2016-12-30 00:14 UTC] ininflamable at gmail dot com
Hi,

I've managed to compile the extension using AppVeyor.

The code has been updated by credomane (https://github.com/credomane/pecl-win32-service). I have made a fork (https://github.com/fawno/pecl-system-win32service) to which I added the build environment that I modified from the InExtension environment (https://github.com/InExtenso/win32service ).

I have deleted the code that restricted the load to CLI SAPI, because I need to be able to interact with the services from the web.

I have tested the following functions:
• win32_create_service => OK
• win32_delete_service => OK
• win32_get_last_control_message => OK
• win32_query_service_status => OK
• win32_set_service_status => OK
• win32_start_service_ctrl_dispatcher => OK
• win32_start_service => OK
• win32_stop_service => OK
 [2017-01-09 16:46 UTC] jean-baptiste at nahan dot fr
Hello,

This crash is normally resolved with the latest version released here: https://github.com/InExtenso/win32service/releases/tag/v0.1.2-RC1

For use outside the client, some function must be limited as inconsistent with the context. In addition, tests must be performed.
 [2017-01-09 16:52 UTC] jean-baptiste at nahan dot fr
If you want remove the "cli" restriction, please open an issue here : https://github.com/InExtenso/win32service/issues

Thanks
 [2017-01-10 10:02 UTC] jean-baptiste at nahan dot fr
New version is available here: https://github.com/InExtenso/win32service/releases/tag/v0.1.2-RC2
 [2017-01-10 11:43 UTC] jean-baptiste at nahan dot fr
Version 1.3-dev is available here for test : https://github.com/InExtenso/win32service/issues/11#issuecomment-271554528

This version allows to use this extension with all SAPI. Please test and feedback if possible.
 [2017-05-02 14:17 UTC] cmb@php.net
-Status: Assigned +Status: Closed
 [2017-05-02 14:17 UTC] cmb@php.net
Since win32service 0.2.0 has already been released, this ticket
can be closed.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jan 18 23:01:24 2020 UTC