php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #73660 lxr.php.net is not available anymore
Submitted: 2016-12-05 19:51 UTC Modified: 2018-02-24 14:21 UTC
Votes:6
Avg. Score:4.3 ± 0.9
Reproduced:6 of 6 (100.0%)
Same Version:1 (16.7%)
Same OS:0 (0.0%)
From: cmb@php.net Assigned:
Status: Re-Opened Package: Systems problem
PHP Version: Irrelevant OS: n/a
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: cmb@php.net
New email:
PHP Version: OS:

 

 [2016-12-05 19:51 UTC] cmb@php.net
Description:
------------
At least since today, trying to access <http://lxr.php.net/> results in a 502 Proxy Error:

Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /.

Reason: Error reading from remote server


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-12-05 22:25 UTC] sobak@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: sobak
 [2016-12-05 22:25 UTC] sobak@php.net
Seems to work now, but of course feel free to Re-Open if the problem persists in your case.
 [2016-12-05 23:16 UTC] cmb@php.net
Works again for me, too. Thanks!
 [2017-01-03 12:47 UTC] cmb@php.net
-Status: Closed +Status: Re-Opened
 [2017-01-03 12:47 UTC] cmb@php.net
At least since yesterday lxr.php.net isn't available anymore, due
to the proxy error.
 [2017-01-11 06:04 UTC] krakjoe@php.net
-Status: Re-Opened +Status: Closed
 [2017-01-11 06:04 UTC] krakjoe@php.net
Fixed again.
 [2017-04-08 23:28 UTC] slevy1 at pipeline dot com
Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /.

Reason: Error reading from remote server

Apache/2.4.18 (Ubuntu) Server at lxr.php.net Port 80
 [2017-04-09 04:43 UTC] levim@php.net
The server lxr.room11.org has lxr up and running and includes php-src and a lot of other projects. We're still working on the getting redundancy and load balancing working for lxr.room11.org. However I figured I would share the url here since lxr.php.net goes down quite a bit and may be useful.
 [2017-04-09 04:50 UTC] sobak@php.net
-Status: Closed +Status: Re-Opened -Assigned To: sobak +Assigned To:
 [2017-04-09 04:50 UTC] sobak@php.net
It's good to have working external service at least but this bug should be reopened anyway.
 [2017-06-27 18:02 UTC] jhdxr@php.net
lxr.room11.org seems to be down as well, is there alternative?
 [2018-02-24 14:21 UTC] cmb@php.net
-Package: Website problem +Package: Systems problem
 [2018-02-24 14:21 UTC] cmb@php.net
While lxr.php.net appears to be still down (or down again),
lxr.room11.org is available.
 [2019-01-03 06:00 UTC] consatan at gmail dot com
lxr.room11.org is down.
 [2019-01-14 14:15 UTC] php at yopmail dot com
As an alternative, I found https://php-lxr.adamharvey.name which is working (for now...)
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Aug 25 20:01:27 2019 UTC