php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #71830 Segmentation fault on clone
Submitted: 2016-03-15 17:11 UTC Modified: 2016-03-15 17:17 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: feyowuf at dlemail dot ru Assigned:
Status: Duplicate Package: *General Issues
PHP Version: 7.0.4 OS: Linux 3.12
Private report: No CVE-ID: None
 [2016-03-15 17:11 UTC] feyowuf at dlemail dot ru
Description:
------------
Segmentation fault happens in some circumstances when cloning an object.

Test script:
---------------
clone new class {
    public function __clone() {
        clone $this;
    }
};

Expected result:
----------------
Some sort of Fatal Error

Actual result:
--------------
Segmentation fault

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-03-15 17:17 UTC] nikic@php.net
-Status: Open +Status: Duplicate
 [2016-03-15 17:17 UTC] nikic@php.net
Duplicate of bug #64196.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Apr 11 21:01:26 2021 UTC