php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #69424 Deep recursion should be documented more prominently
Submitted: 2015-04-10 23:21 UTC Modified: 2015-06-14 15:49 UTC
From: cmb@php.net Assigned: cmb (profile)
Status: Closed Package: Scripting Engine problem
PHP Version: Irrelevant OS: *
Private report: No CVE-ID: None
 [2015-04-10 23:21 UTC] cmb@php.net
Description:
------------
---
From manual page: http://www.php.net/functions.user-defined
---
Apparently, many users don't expect PHP to crash on infinite
recursion[1]. Therefore I suggest to document this issue more
clearly, at least.

[1] 3 reproducible crashes due to infinite recursion have been
reported during the last 10 days: bug #69346, bug #69397, bug
#69423. There seem to be a lot of older reports.


Patches

recursion.patch (last revision 2015-04-10 23:21 UTC by cmb)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-06-14 15:48 UTC] cmb@php.net
Automatic comment from SVN on behalf of cmb
Revision: http://svn.php.net/viewvc/?view=revision&revision=336952
Log: documented that infinite recursion is considered to be a programming error (fixes #69424)
 [2015-06-14 15:49 UTC] cmb@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: cmb
 [2015-06-14 15:49 UTC] cmb@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Aug 19 21:05:45 2022 UTC