php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69260 NetBSD TCP_INFO is similar to FreeBSD
Submitted: 2015-03-19 08:24 UTC Modified: 2015-03-23 08:30 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: he at NetBSD dot org Assigned: nikic (profile)
Status: Closed Package: Compile Failure
PHP Version: 5.6.6 OS: NetBSD
Private report: No CVE-ID: None
 [2015-03-19 08:24 UTC] he at NetBSD dot org
Description:
------------
NetBSD has recently inherited TCP_INFO from FreeBSD,
so the use needs to be similar to FreeBSD, not Linux.

This fix needs to be applied to php 5.5.22 as well.


Expected result:
----------------
Build should succeed on NetBSD 7 (either 7.0_BETA or 7.99.5 aka. -current)


Actual result:
--------------
/scratch/www/php-fpm/work/php-5.6.6/sapi/fpm/fpm/fpm_sockets.c:447:11: error: no member named 'tcpi_sacked' in 'struct tcp_info'; did you mean '__tcpi_sacked'?
        if (info.tcpi_sacked == 0) {
                 ^~~~~~~~~~~
                 __tcpi_sacked
/usr/include/netinet/tcp.h:168:11: note: '__tcpi_sacked' declared here
        uint32_t        __tcpi_sacked;
                        ^
/scratch/www/php-fpm/work/php-5.6.6/sapi/fpm/fpm/fpm_sockets.c:452:18: error: no member named 'tcpi_unacked' in 'struct tcp_info'; did you mean '__tcpi_unacked'?
                *cur_lq = info.tcpi_unacked;
                               ^~~~~~~~~~~~
                               __tcpi_unacked
/usr/include/netinet/tcp.h:167:11: note: '__tcpi_unacked' declared here
        uint32_t        __tcpi_unacked;
                        ^
/scratch/www/php-fpm/work/php-5.6.6/sapi/fpm/fpm/fpm_sockets.c:456:18: error: no member named 'tcpi_sacked' in 'struct tcp_info'; did you mean '__tcpi_sacked'?
                *max_lq = info.tcpi_sacked;
                               ^~~~~~~~~~~
                               __tcpi_sacked
/usr/include/netinet/tcp.h:168:11: note: '__tcpi_sacked' declared here
        uint32_t        __tcpi_sacked;
                        ^
3 errors generated.
*** [sapi/fpm/fpm/fpm_sockets.lo] Error code 1


Patches

fpm_socket.c.patch (last revision 2015-03-19 08:25 UTC by he at NetBSD dot org)

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-03-19 08:40 UTC] laruence@php.net
should also add a version checking of NetBSD check as well?
 [2015-03-19 08:45 UTC] he at NetBSD dot org
I don't think a version check is required.
There's already a check surrounding this code
which is dependent on TCP_INFO being defined,
which should be a sufficient check?
 [2015-03-19 09:32 UTC] laruence@php.net
okey, if you are sure (since I can not see that check just from patch :))
 [2015-03-23 08:29 UTC] he at NetBSD dot org
This bug can now be closed.
The associated pull request 1182 has been merged.
 [2015-03-23 08:30 UTC] nikic@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: nikic
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Mar 03 23:01:32 2024 UTC