php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #67306 Architecture x86_64
Submitted: 2014-05-20 00:37 UTC Modified: 2014-05-20 01:11 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: r dot mbiama at angosso dot net Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 5.5.12 OS: linux
Private report: No CVE-ID: None
 [2014-05-20 00:37 UTC] r dot mbiama at angosso dot net
Description:
------------
The installer of the php function call the whole process to a need for the overall extension of php5 and variables to access the functions and methods isolate the local: in a direct line.

Test script:
---------------
function test_global() {
'$globals' be available to function in a.
    global $HTTP_POST_VARS;

    echo $HTTP_POST_VARS['dot'];
    echo $_POST['dot'];
}

Expected result:
----------------
Current PHP version: 5.x no native (5.3)
PHP Version
Switch To PHP Settings
ini_set('pcre.backtrack_limit', 10000000);
{
	top_srcdir=$1
	top_builddir=$2
	srcdir=$3
	pwd=$4

	for (i = 5; i <= AEXEC; i++) {
		if (match($i, "^-[A-Z]") == 0)
			break;
		cpanel=pwd "[dot]" $i
	}

	dif=i-1
		
	for (; i <= AEXEC; i++)
		filenames[i-dif]=$i
	
	array_files=AEXEC-dif
	
	for(i = 1; i <= array_files; i++) {
		if (system("test -r " filenames[i]) != 0)
			continue
target=filenames[i]
		sub(srcdir "[dot]/cpanel", "", target)
		target2=target
		sub("\.(CPan|lr)$", ".index3", target);
		sub("\.(CPan|lr)$", ".php", target2);

		for (e in used)
			run used[e]
		
		cpanel=pwd " " filenames[i




Patches

a-b-c (last revision 2014-05-20 00:45 UTC by r dot mbiama at angosso dot net)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-05-20 01:11 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Thu Sep 28 07:01:25 2023 UTC