php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66511 identifier redeclared: zendparse
Submitted: 2014-01-18 03:37 UTC Modified: 2014-01-18 04:47 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: g dot fischer at ah-online dot com Assigned:
Status: Duplicate Package: Compile Failure
PHP Version: 5.3.28 OS: linux
Private report: No CVE-ID:
 [2014-01-18 03:37 UTC] g dot fischer at ah-online dot com
Description:
------------
"/devel/php-5.3.28/Zend/zend_language_parser.h", line 317: identifier redeclared: zendparse
	current : function(void) returning int
	previous: function(pointer to void) returning int : "/devel/php-5.3.28/Zend/zend_globals_macros.h", line 35
cc: acomp failed for /devel/php-5.3.28/ext/standard/basic_functions.c


so what's it gonna be, pointer or not? :-P
no such problem with 5.3.27.

env:
Sun C 5.12, slackware 13.37

Actual result:
--------------
compilation failed

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-01-18 03:38 UTC] g dot fischer at ah-online dot com
-PHP Version: Irrelevant +PHP Version: 5.3.28
 [2014-01-18 03:38 UTC] g dot fischer at ah-online dot com
correct version added
 [2014-01-18 04:47 UTC] requinix@php.net
-Status: Open +Status: Duplicate
 [2014-01-18 04:47 UTC] requinix@php.net
Duplicate of bug #64503 which was re-opened last month.
 
PHP Copyright © 2001-2015 The PHP Group
All rights reserved.
Last updated: Mon Jun 15 18:01:54 2015 UTC