php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65109 Extraneous empty paragraphs in generated HTML
Submitted: 2013-06-24 10:02 UTC Modified: 2017-10-24 05:14 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: pet dot draexler at gmail dot com Assigned: salathe (profile)
Status: Assigned Package: Doc Build problem
PHP Version: Irrelevant OS: Windows 7
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2013-06-24 10:02 UTC] pet dot draexler at gmail dot com
Description:
------------
Hello,
I use Google Chrome 27.0.1453.116 m on Windows and I see formatting of docs of 
money_format() incorrectly. See the picture 
http://s23.postimg.org/xuc3r63zv/php_net_bug.png.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-06-24 22:46 UTC] philip@php.net
-Status: Open +Status: Feedback
 [2013-06-24 22:46 UTC] philip@php.net
Can you check the HTML source around the broken parts and paste what you find?
 [2013-06-25 05:03 UTC] gabri dot ns at gmail dot com
from the screenshot, what i think is that it lack of stylesheet since there is no 
bounding box at all. i'm using the same browser and the same version, that is the 
latest, and its fine here.

try refreshing your browser.
 [2013-06-25 07:01 UTC] philip@php.net
-Status: Feedback +Status: Verified -Type: Documentation Problem +Type: Bug -Package: Strings related +Package: Website problem
 [2013-06-25 07:01 UTC] philip@php.net
Ah, verified, this bug is specific to the beta site. Marking this as a web 
problem.

Thank you for the bug report! :)
 [2013-06-27 15:15 UTC] gabri dot ns at gmail dot com
When look into the doc.css,
I see some thing like this

.docs .refentry .parameters .title + p.para + dl,
.docs .refsect1.examples .title + p.para + *,
.docs .refsect1.seealso .title + p.para + * {
    margin-top:-1.5em;
    /* there's a p tag that has whitespace (not :empty).
       This simply covers it up */
}

The comment was explaining that this entry is used
to cover up other element. However, there is p.para
element that actually didn't empty. When i disable
this entry, it fix the problem.
 [2013-06-27 18:09 UTC] levim@php.net
I should have already posted that I know why this is an issue. Unfortunately it 
will most likely require a change in the PhD system. Short-term we can remove the 
style which will cause large spacing issues on the majority of pages but will fix 
the formatting for these cases.
 [2013-07-04 11:30 UTC] dragoonis@php.net
I have fixed this using JS and took out the CSS hack that didn't work and caused  
problematic formatting issues for all types of users.

Now users with JS (most of them) will not experience this layout problem. Users 
without JS will see a little extra spacing but if they don't have JS turned 
on then this isn't their worst problem.

Once PHD is fixed to remove this random empty paragraph tag then this JS can be 
removed.

https://github.com/php/web-php/commit/3042ff3b32f71c4b6b76329c128e56c8de22870e

Thanks,
Paul
 [2014-03-04 04:30 UTC] levim@php.net
-Status: Verified +Status: Closed -Assigned To: +Assigned To: levim
 [2014-03-04 04:30 UTC] levim@php.net
The PHD changes would be quite substantial and nobody has been up to the task. I'm going to mark this as closed as it is very unlikely to happen.
 [2014-03-04 08:54 UTC] salathe@php.net
-Summary: Formatting of docs +Summary: Extraneous empty paragraphs in generated HTML -Status: Closed +Status: Re-Opened -Package: Website problem +Package: Doc Build problem -Assigned To: levim +Assigned To: salathe
 [2014-03-04 08:54 UTC] salathe@php.net
Re-opening. Just because it's a PhD issue which might take a while for anyone to look at or fix, doesn't mean we should close the ticket.
 [2017-10-24 05:14 UTC] kalle@php.net
-Status: Re-Opened +Status: Assigned
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC