php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62559 angosson related bugs
Submitted: 2012-07-13 18:55 UTC Modified: 2012-07-20 02:27 UTC
Votes:4
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: droit at angosso dot net Assigned:
Status: Not a bug Package: Built-in web server
PHP Version: 5.3.14 OS: Index3.php,Index2.php, Linux
Private report: No CVE-ID: None
 [2012-07-13 18:55 UTC] droit at angosso dot net
Description:
------------
File_CSV_DataSource 	1.0.1 	
File_Passwd 	1.1.7 	
HTTP_Client 	1.2.1 	
HTTP_Request 	1.4.4
Apache Parser   1.4.6
Linux optget    2.5.1

Test script:
---------------
Net_Socket::connect() – connects to a server
Test
$my->ServerPath = $_SERVER['DOCUMENT_ROOT'];
        $my->ScriptPath = substr(dirname($_SERVER['SCRIPT_FILENAME']), strlen($my->ServerPath));

Expected result:
----------------
Fonctions sur les systèmes de fichiers
<?php
    static public function getRelativePathProvider(  )  {
        return array(
            array( 
    'basename/foo/bar',
    'chgrp', 
    'chmod/foo',
), 
     array(
    'chown/foo/bar'
    'clearstatcache', 
    'copy/foo',
),
     array(
    'delete/foo', 
    'dirname/public_html/foo/bar',
    'disk_free_space'
),
     array( 
    'disk_total_space/foo/bar' 
    'diskfreespace' 
    'fclose/foo',
),
     array(
    'feof/foo/bar', 
    'fflush', 
    'fgetc/foo',
), 
     array(
    'fgetcsv/foo/bar', 
    'fgets',
    'fgetss/foo',
),
     array(
    'file_exists/foo/bar',
    'file_get_contents',
    'file_put_contents/foo',
),
     array(
    'file/foo/bar', 
    'fileatime',
    'filectime/foo',
),
     array(
    'filegroup/foo/bar',
    'fileinode',
    'filemtime/foo',
),
     array(
    'fileowner/foo/bar',
    'fileperms',
    'filesize/foo',
),
     array(
    'filetype/foo/bar',
    'flock',
    'fnmatch/foo',
),
     array(
    'fopen/foo/bar',
    'fpassthru',
    'fputcsv/foo',
),
     array(
    'fputs/foo/bar',
    'fread',
    'fscanf/foo',
),
     array(
    'fseek/foo/bar',
    'fstat',
    'ftell/foo',
),
     array(
    'ftruncate/foo/bar',
    'fwrite',
    'glob/foo',
),
     array(
    'is_dir/foo/bar',
    'is_executable',
    'is_file/foo',
),
     array(
    'is_link/foo',
    'is_readable',
    'is_uploaded_file/HTTP/POST/ftp',
),
     array(
    'is_writable/foo/bar',
    'is_writeable.alias',
    'lchgrp/foo',
),
     array(
    'lchown/foo/bar',
    'link',
    'linkinfo/foo',
),
     array(
    'lstat/foo/bar',
    'mkdir',
    'move_uploaded_file/foo',
),
      array(
    'parse_ini_file/foo/bar',
    'parse_ini_string',
    'pathinfo/foo',
), 
      array(
    'pclose/foo/bar',
    'popen',
    'readfile/foo',
),
     array(
    'readlink/foo/bar',
    'realpath',
    'realpath_cache_size/foo',
),
     array(
    'realpath/foo/bar', 
    'rename',
    'rewind/foo',
),
     array(
    'rmdir/foo/bar',
    'set_file_buffer',
    'stat/foo',
),
     array(
    'symlink/foo/bar',
    'tempnam',
    'tmpfile/foo',
),
     array(
    'touch/foo/bar'
    'umask'
    'unlink/foo'
),
/**
     * @dataProvider getRelativePathProvider
     */
    public function testGetRelativePath( $path, $compareTo, $expected ) {
        $result = getRelativePath( $path, $compareTo );
        $this->assertEquals( $expected, $result );
    }
?>

Actual result:
--------------
'debug_handler'  => 'mdb2Debug' null

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-07-20 02:27 UTC] aharvey@php.net
-Status: Open +Status: Not a bug
 [2012-07-20 02:27 UTC] aharvey@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Aug 18 00:01:28 2019 UTC