php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62350 $HTTP_SERVER_CGI
Submitted: 2012-06-18 12:26 UTC Modified: 2012-06-18 23:06 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:0 of 0 (0.0%)
From: postmaster at angosso dot net Assigned:
Status: Not a bug Package: Output Control
PHP Version: 5.3.14 OS: index.php
Private report: No CVE-ID: None
 [2012-06-18 12:26 UTC] postmaster at angosso dot net
Description:
------------
<?php
echo http_build_url("http://user@www.example.com/pub/index.php?a=b#files",
         array(
                 "scheme" => "ftp",
                 "host" => "ftp.angosso.net",
                 "path" => "files/web.config/angosso2",
                  "query" => "a=b"
          ),
         HTTP_URL_STRIP_AUTH | HTTP_URL_JOIN_PATH | HTTP_URL_JOIN_QUERY | HTTP_URL_STRIP_FRAGMENT
);
?>


Test script:
---------------
<?php
echo http_build_url("http://angosso2@www.angosso.net/pub/index.php?a=b#files",
         array(
                 "scheme" => "ftp",
                 "host" => "ftp.angosso.net",
                 "path" => "files/web.config/angosso2",
                  "query" => "a=b"
          ),
}
*/

$res = preg_match("/username=\"([^\"]+)\"/i", $txt, $match);
$data['username'] = $match[1];
$res = preg_match('/nonce=\"([^\"]+)\"/i', $txt, $match);
$data['nonce'] = $match[1];
$res = preg_match('/nc=([0-9]+)/i', $txt, $match);
$data['nc'] = $match[1];
$res = preg_match('/cnonce=\"([^\"]+)\"/i', $txt, $match);
$data['cnonce'] = $match[1];
$res = preg_match('/qop=([^,]+)/i', $txt, $match);
$data['qop'] = $match[1];
$res = preg_match('/uri=\"([^\"]+)\"/i', $txt, $match);
$data['uri'] = $match[1];
$res = preg_match('/response=\"([^\"]+)\"/i', $txt, $match);
$data['response'] = $match[1];

//return $needed_parts ? false : $data;
return $data;

}
         HTTP_URL_STRIP_AUTH | HTTP_URL_JOIN_PATH | HTTP_URL_JOIN_QUERY | HTTP_URL_STRIP_FRAGMENT
);
?>


Expected result:
----------------
[http://www.angosso.net/pub/home/index.php?=a,arg1,arg2]

Actual result:
--------------
HTTP Error 404.0 - Not Found
Detailed Error Information
Module	IIS Web Core
Notification	MapRequestHandler
Handler	StaticFile
Error Code	0x80070002
Requested URL	http://angosso.net:80/angosso2
Physical Path	E:\web\angosso2\angosso2
Logon Method	Anonymous
Logon User	Anonymous

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-06-18 21:28 UTC] mail+php at requinix dot net
How to submit a bug report:
https://bugs.php.net/how-to-report.php

1. Title seems irrelevant.
2. Package seems wrong.
3. Description doesn't actually include a description.
4. Description is just a cut-and-paste from the man page on http_build_url.
5. Test script is very incomplete (not to mention the syntax problems).
6. Expected result is... I can't even tell why that's the expected result.
7. Actual result indicates some completely different problem.
 [2012-06-18 23:06 UTC] johannes@php.net
-Status: Open +Status: Not a bug
 [2012-06-18 23:06 UTC] johannes@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed May 18 10:05:45 2022 UTC