php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62295 Unable to select intl extension for Windows MSI installer
Submitted: 2012-06-11 16:24 UTC Modified: 2012-07-23 14:17 UTC
Votes:2
Avg. Score:4.5 ± 0.5
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: chris at crgs dot co dot uk Assigned:
Status: Closed Package: Windows Installer
PHP Version: 5.3.13 OS: Windows Server 2008 R2
Private report: No CVE-ID: None
 [2012-06-11 16:24 UTC] chris at crgs dot co dot uk
Description:
------------
The current Windows MSI installer available from
http://windows.php.net/download/ (php-5.3.13-nts-Win32-VC9-x86.msi)
does not include an option to install the 'intl' extension.

The current list of available extensions are:
bzip2
Curl
Enchant
EXIF
Fileinfo
GD2
Gettext
GMP
IMAP
LDAP
Multi-Byte String
MySQL
MySQLi
OpenSSL
Oracle (10)
Oracle (11g)
PDO (with various database extensions)
PostgreSQL
Shared Memory
SNMP
SOAP
Sockets
SQLite
SQLite 3
Sybase
Tidy
XML-RPC
XSL

This extension should have been added to the list according to Bug #49986, but it was either removed at some point, or never got added in the first place.

Expected result:
----------------
Option to install the intl extension in the Windows MSI installer, or included by default

Actual result:
--------------
intl extension not installed by default, and cannot be selected in the installer

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-07-23 14:17 UTC] chris at crgs dot co dot uk
-Status: Open +Status: Closed
 [2012-07-23 14:17 UTC] chris at crgs dot co dot uk
Seems to be fixed in the Windows PHP 5.3.15 installer.

Many thanks!
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Oct 03 18:05:53 2022 UTC