php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49986 intl extension missing/DLLs for intl extension missing
Submitted: 2009-10-24 14:22 UTC Modified: 2009-10-26 11:25 UTC
From: a dot schilder at gmx dot de Assigned: pajoye
Status: Closed Package: Windows Installer
PHP Version: 5.3.1RC2 OS: Windows 2003 Server 64bit
Private report: No CVE-ID:
 [2009-10-24 14:22 UTC] a dot schilder at gmx dot de
Description:
------------
Hi,

I just tried to install PHP 5.3.1RC2 with Apache (VC9 Version from Apachelounge).

1) The MSI-Installer didn't offer to install the intl-Extension.

2) So I downloaded the ZIP package and copied is manually. But Apache didn't want to restart - no error message in the error.log.

I did some test, tried it with a snapshot etc. but all tests failed. Then I saw, that there were only two DLLs in the PHP folder:
icuuc38.dll
icuin38.dll

I remembered that there were some more in a previous RC1 installation:
icuuc38.dll
icuin38.dll
icudt38.dll
icuio38.dll
icule38.dll
iculx38.dll
icutu38.dll

I don't know what these DLLs are good for, but I copied them to the PHP folder of the new installation and now Apache started again.

So there seems to be a problem with the DLLs in the ZIP package.



Reproduce code:
---------------
n/a

Expected result:
----------------
1) intl extension with the installer.

2) Missing DLLs included in the ZIP package.

Actual result:
--------------
1) intl extension not available with the installer.

2) DLLs missing in the ZIP package.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-10-24 19:52 UTC] svn@php.net
Automatic comment from SVN on behalf of pajoye
Revision: http://svn.php.net/viewvc/?view=revision&revision=289905
Log: - #49986, fix ICU DLLs path
 [2009-10-24 19:53 UTC] pajoye@php.net
Next snap will contain the fix for the ICU DLL. I will fix the installer later and be sure that intl is supported before 5.3.1 final.
 [2009-10-26 11:25 UTC] pajoye@php.net
Fixed in 5.3+. MSI installs now intl as well (you have to select it).
 [2012-05-18 16:14 UTC] chris at crgs dot co dot uk
Hi,

I have just attempted to install the intl extension using the the PHP 5.3.13 Windows installer (http://windows.php.net/download), but can't see it anywhere on the 'Choose items to install' list.

Did this change ever get committed?

If not, please could it be?
 [2012-07-23 14:18 UTC] chris at crgs dot co dot uk
Fixed in the Windows PHP 5.3.15 installer.

Many thanks!
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Mon Apr 21 12:02:07 2014 UTC