php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #61921 ldap_parse_result returns server controls
Submitted: 2012-05-03 11:32 UTC Modified: 2017-01-09 16:56 UTC
Votes:6
Avg. Score:4.2 ± 0.9
Reproduced:4 of 4 (100.0%)
Same Version:2 (50.0%)
Same OS:4 (100.0%)
From: etienne at lamaisondebarbie dot ch Assigned: mcmic (profile)
Status: Wont fix Package: LDAP related
PHP Version: 5.4Git-2012-05-03 (Git) OS: Debian testing
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2012-05-03 11:32 UTC] etienne at lamaisondebarbie dot ch
Description:
------------
ldap_parse_result returns any server controls in an array that mimic ASN.1. ldap_set_option has been modified to accept such array for server and client controls.

This is not a duplicate of bug #34492 as this patch handles any server controls and it's a more elegant solution for paged result than resolution of bug #42060.


Patches

ldap_parse_result.patch (last revision 2012-05-03 11:33 UTC by etienne at lamaisondebarbie dot ch)

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-02-22 08:32 UTC] ab@php.net
-Assigned To: +Assigned To: ab
 [2015-07-01 15:36 UTC] ab@php.net
-Assigned To: ab +Assigned To: mcmic
 [2015-07-01 15:36 UTC] ab@php.net
Hi Come,

please check whether this patch is still applicable for 5.6+ :) If you think you can adapt it, please do. Otherwise just close.

Btw not sure what the attached PR has to do with this bug, probably added by some mistake.

Thanks.
 [2017-01-09 16:56 UTC] heiglandreas@php.net
-Status: Assigned +Status: Wont fix
 [2017-01-09 16:56 UTC] heiglandreas@php.net
As we didn't get any feedback on this I'll close the issue.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Jun 18 15:01:27 2019 UTC