php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #34492 ldap_parse_result() doesn't provide serverctrls value
Submitted: 2005-09-13 17:57 UTC Modified: 2010-08-11 19:36 UTC
Votes:66
Avg. Score:4.8 ± 0.5
Reproduced:60 of 61 (98.4%)
Same Version:26 (43.3%)
Same OS:39 (65.0%)
From: iarenaza at escomposlinux dot org Assigned:
Status: Duplicate Package: *General Issues
PHP Version: 4CVS-2005-09-13 (snap) OS: *
Private report: No CVE-ID:
 [2005-09-13 17:57 UTC] iarenaza at escomposlinux dot org
Description:
------------
In order to use LDAP Paged Results Control Extension (see RFC 2692), we need to be able to access this value through OpenLDAP's ldap_parse_results()'s serverctrls parameter.

Unfortunately, this isn't available in PHP's ldap_parse_result(). I have developed (and tested) a patch against php4-STABLE-200509131447 (should be easily applyable to php5-cvs) to provide this functionality.

I can provide the patch on request (it 82 lines long, so I won't post it here as recommended).




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-09-13 23:35 UTC] martin at catalyst dot net dot nz
This is really needed to fetch large resultsets from LDAP without being memory-bound.
 [2009-09-25 12:03 UTC] gehrig at ishd dot de
Anything new on this one? This is still not fixed neither in PHP 5.2.x 
nor in 5.3.x nor in PHP 6 and a patch would be the only way to handle 
large Active Directory result sets.
 [2009-10-27 22:10 UTC] clem dot oudot at gmail dot com
Hello,

I develop a simple LDAP password tool (http://ltb-project.org/wiki/documentation/self-service-password) and need to use the LDAP ppolicy control.

I face the same issue because I need to recover the control in the response. So this issue concerns all LDAP controls that are sent by the client and got a server control response.

Thanks for your help.
 [2010-08-05 00:59 UTC] qmt9z3 at yahoo dot com
Iñaki Arenaza who opened this request for feature is also willing to
provide the patch. This of value to anyone dealing with huge search
results and intend to go thru a pagination process. Is there a reason
why this is not pursued? I don't believe there is anything additional
needed to be done other than applying patches and testing. What does
it take to have the patch walked into the future releases?
 [2010-08-11 18:43 UTC] thomas dot matthews at gmail dot com
I've been watching this request for a few years and recently have come across a 
requirement to use this feature.  Thought I would add a comment in hopes to bring 
exposure to this change request.
 [2010-08-11 19:31 UTC] iarenaza at escomposlinux dot org
For those still tracking/insterested in this bug, you should actually follow bug #42060. That's where a better patch has been provided and even committed into trunk (but still not committed to any stable branch).

In fact, this bug can be closed as far as I'm concerned.

Saludos.
Iñaki.
 [2010-08-11 19:36 UTC] pajoye@php.net
-Status: Open +Status: Duplicate -Package: Feature/Change Request +Package: *General Issues
 [2010-08-11 19:36 UTC] pajoye@php.net
See #42060
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 15:02:26 2014 UTC