php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61710 Unable to compile the extension
Submitted: 2012-04-13 06:19 UTC Modified: 2012-04-13 06:47 UTC
From: phpconnect at gmail dot com Assigned:
Status: Duplicate Package: xhprof (PECL)
PHP Version: 5.4.0 OS: Ubuntu
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: phpconnect at gmail dot com
New email:
PHP Version: OS:

 

 [2012-04-13 06:19 UTC] phpconnect at gmail dot com
Description:
------------
when i run make command giving showing the error and extension not generating 

Expected result:
----------------
Generated extension .so file

Actual result:
--------------
/bin/bash /xhprof-0.9.2/extension/libtool --mode=compile cc  -I. -I/xhprof-
0.9.2/extension -DPHP_ATOM_INC -I/xhprof-0.9.2/extension/include -I/xhprof-
0.9.2/extension/main -I/xhprof-0.9.2/extension -I/usr/include/php5 -
I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -
I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -D_LARGEFILE_SOURCE -
D_FILE_OFFSET_BITS=64  -DHAVE_CONFIG_H  -g -O2   -c /xhprof-
0.9.2/extension/xhprof.c -o xhprof.lo 
libtool: compile:  cc -I. -I/xhprof-0.9.2/extension -DPHP_ATOM_INC -I/xhprof-
0.9.2/extension/include -I/xhprof-0.9.2/extension/main -I/xhprof-0.9.2/extension 
-I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -
I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib 
-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CONFIG_H -g -O2 -c /xhprof-
0.9.2/extension/xhprof.c  -fPIC -DPIC -o .libs/xhprof.o
/xhprof-0.9.2/extension/xhprof.c:236:1: warning: 'visibility' attribute ignored 
[-Wattributes]
/xhprof-0.9.2/extension/xhprof.c:240:28: warning: 'visibility' attribute ignored 
[-Wattributes]
/xhprof-0.9.2/extension/xhprof.c: In function 'hp_get_function_name':
/xhprof-0.9.2/extension/xhprof.c:898:10: warning: assignment discards 'const' 
qualifier from pointer target type [enabled by default]
/xhprof-0.9.2/extension/xhprof.c:909:13: warning: assignment discards 'const' 
qualifier from pointer target type [enabled by default]
/xhprof-0.9.2/extension/xhprof.c:911:13: warning: assignment discards 'const' 
qualifier from pointer target type [enabled by default]
/xhprof-0.9.2/extension/xhprof.c:930:34: error: 'znode_op' has no member named 
'u'
/xhprof-0.9.2/extension/xhprof.c:963:9: warning: passing argument 1 of 
'hp_get_base_filename' discards 'const' qualifier from pointer target type 
[enabled by default]
/xhprof-0.9.2/extension/xhprof.c:856:14: note: expected 'char *' but argument is 
of type 'const char *'
/xhprof-0.9.2/extension/xhprof.c: In function 'hp_execute_internal':
/xhprof-0.9.2/extension/xhprof.c:1650:24: error: 'znode_op' has no member named 
'u'
/xhprof-0.9.2/extension/xhprof.c:1651:59: error: 'struct <anonymous>' has no 
member named 'return_reference'
/xhprof-0.9.2/extension/xhprof.c:1652:25: error: 'znode_op' has no member named 
'u'
/xhprof-0.9.2/extension/xhprof.c: In function 'hp_compile_file':
/xhprof-0.9.2/extension/xhprof.c:1683:3: warning: passing argument 1 of 
'hp_get_base_filename' discards 'const' qualifier from pointer target type 
[enabled by default]
/xhprof-0.9.2/extension/xhprof.c:856:14: note: expected 'char *' but argument is 
of type 'const char *'
make: *** [xhprof.lo] Error 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-04-13 06:47 UTC] aharvey@php.net
Duplicate of bug #61674.
 [2012-04-13 06:47 UTC] aharvey@php.net
-Status: Open +Status: Duplicate
 [2012-12-20 18:07 UTC] stickgrinder at gmail dot com
Exactly the same problem here. Any clue/workaround?
 [2012-12-20 18:09 UTC] stickgrinder at gmail dot com
Sorry, I missed the duplicate message. :( nevermind.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Sep 22 03:01:26 2019 UTC