php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #60225 sapi/cli/php for tests/bug60082.php keeps running after "make test"
Submitted: 2011-11-05 17:23 UTC Modified: 2016-07-01 14:49 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: dirk at haun-online dot de Assigned: cmb (profile)
Status: Closed Package: Testing related
PHP Version: 5.3.9RC1 OS: Linux
Private report: No CVE-ID: None
 [2011-11-05 17:23 UTC] dirk at haun-online dot de
Description:
------------
After doing a "make test" for PHP 5.3.9rc1 (and after it finished), I still have 
a php process running:

dirk@metis:php-5.3.9RC1> ps ax | grep php
28645 pts/0    R      8:53 /home/dirk/php-5.3.9RC1/sapi/cli/php -n -c 
/home/dirk/php-5.3.9RC1/tmp-php.ini -d output_handler= -d open_basedir= -d 
safe_mode=0 -d disable_functions= -d output_buffering=Off -d 
error_reporting=32767 -d display_errors=1 -d display_startup_errors=1 -d 
log_errors=0 -d html_errors=0 -d track_errors=1 -d report_memleaks=1 -d 
report_zend_debug=0 -d docref_root= -d docref_ext=.html -d error_prepend_string= 
-d error_append_string= -d auto_prepend_file= -d auto_append_file= -d 
magic_quotes_runtime=0 -d ignore_repeated_errors=0 -d precision=14 -d 
unicode.runtime_encoding=ISO-8859-1 -d unicode.script_encoding=UTF-8 -d 
unicode.output_encoding=UTF-8 -d unicode.from_error_mode=U_INVALID_SUBSTITUTE -d 
extension_dir=/home/dirk/php-5.3.9RC1/modules/ -d session.auto_start=0 -d 
zlib.output_compression=Off -d mbstring.func_overload=0 -f /home/dirk/php-
5.3.9RC1/ext/spl/tests/bug60082.php


Test script:
---------------
Nothing special - I just did the usual ./configure ..., then make, then make test

Expected result:
----------------
I expect all PHP CLI processes to be finished by the time "make test" finishes.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-11-08 11:00 UTC] dirk at haun-online dot de
The original report was for Ubuntu 11.04:
Linux metis 2.6.38-11-generic #50-Ubuntu SMP Mon Sep 12 21:18:14 UTC 2011 i686 i686 i386 GNU/Linux

Complete report is here: http://news.php.net/php.qa.reports/30659

The same thing is happening on Ubuntu 8.04:
Linux cpreqtest 2.6.24-29-generic #1 SMP Tue Oct 11 15:26:26 UTC 2011 i686 GNU/Linux
 [2016-07-01 14:49 UTC] cmb@php.net
-Status: Open +Status: Closed -Package: Unknown/Other Function +Package: Testing related -Assigned To: +Assigned To: cmb
 [2016-07-01 14:49 UTC] cmb@php.net
This issue had been reported before as bug #60186, and so the test
had been fixed by skipping it for FreeBSD systems; this report had
obviously been overlooked. Sorry.

Anyhow, the test had been meaningless as of PHP 5.4.0, and so had
been removed altogether.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Jul 19 22:01:26 2019 UTC