php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57833 PDO shouldn't disable dynamic build
Submitted: 2007-09-11 16:36 UTC Modified: 2017-12-17 11:59 UTC
From: jdolecek at netbsd dot org Assigned:
Status: Duplicate Package: PDO related
PHP Version: 5.2.1 OS: Mac OS X 10.4.10
Private report: No CVE-ID: None
 [2007-09-11 16:36 UTC] jdolecek at netbsd dot org
Description:
------------
config.m4 currently disables dynamic build when building on Darwin. After running phpize, the build directory ends up with do-nothing Makefile and the extension cannot build.

This is due to fact that dynamic PDO extension didn't work. Fix for this is submitted as PHP bug #42629, please also fix PDO configure script.

Fix:

--- config.m4.orig      2006-05-02 04:47:43.000000000 +0200
+++ config.m4
@@ -34,22 +34,6 @@ if test "$PHP_PDO" != "no"; then

   PHP_PDO_PEAR_CHECK

-  if test "$ext_shared" = "yes" ; then
-    case $host_alias in
-      *darwin*)
-        if test "$pdo_running_under_pear" = "1"; then
-          AC_MSG_ERROR([
-Due to the way that loadable modules work on OSX/Darwin, you need to
-compile the PDO package statically into the PHP core.
-
-Please follow the instructions at: http://netevil.org/node.php?nid=202
-for more detail on this issue.
-          ])
-        fi
-        ext_shared=no
-        ;;
-    esac
-  fi
   PHP_NEW_EXTENSION(pdo, pdo.c pdo_dbh.c pdo_stmt.c pdo_sql_parser.c pdo_sqlstate.c, $ext_shared)
   ifdef([PHP_ADD_EXTENSION_DEP],
   [


Reproduce code:
---------------
phpize
./configure --with-pdo
make

Expected result:
----------------
Extension builds

Actual result:
--------------
Build writes:

Build complete.
Don't forget to run 'make test'.

---
but nothing is actually done.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-10-24 23:34 UTC] kalle@php.net
-Package: PDO +Package: PDO related
 [2017-12-17 11:59 UTC] nikic@php.net
-Status: Open +Status: Duplicate
 [2017-12-17 11:59 UTC] nikic@php.net
Duplicate of bug #75616, which just got merged -- 10 years later :)
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Jul 16 16:01:26 2019 UTC