php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75616 PDO extension doesn't allow to be built shared on Darwin
Submitted: 2017-12-03 12:41 UTC Modified: 2017-12-04 08:01 UTC
From: jdolecek at NetBSD dot org Assigned:
Status: Closed Package: PDO Core
PHP Version: 7.2.0 OS: MacOS,pkgsrc
Private report: No CVE-ID: None
 [2017-12-03 12:41 UTC] jdolecek at NetBSD dot org
Description:
------------
NetBSD package system pkgsrc maintains several patches, which we'd like to feed upstream. This is one of them.

ext/pdo/config.m4 explicitely forbid the package to be built shared on Darwin/MacOS/Mac OS X. Actually, shared PDO builds and works just fine on modern Mac OS, so there is no reason for this restriction. The submodules (such as pdo_mysql or pdo_pgsql) also load and work fine.


Patches

patch-ext_pdo_config.m4 (last revision 2017-12-03 12:42 UTC) by jdolecek at NetBSD dot org)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-12-03 12:43 UTC] jdolecek at NetBSD dot org
-Summary: PDO extension doesn't allow to be built shared on Darwon +Summary: PDO extension doesn't allow to be built shared on Darwin
 [2017-12-03 12:43 UTC] jdolecek at NetBSD dot org
Fixed typo in title
 [2017-12-04 08:01 UTC] kalle@php.net
-Status: Open +Status: Verified
 [2017-12-04 08:01 UTC] kalle@php.net
FWIW, the same restriction is in-effect on Windows
 [2017-12-17 11:58 UTC] nikic@php.net
Automatic comment on behalf of jdolecek@NetBSD.org
Revision: http://git.php.net/?p=php-src.git;a=commit;h=11eed9f3ba7429be467b54d8407cfbd6bd7e6f3a
Log: Fixed bug #75616
 [2017-12-17 11:58 UTC] nikic@php.net
-Status: Verified +Status: Closed
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC