php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #55319 windows version not detected as it should be
Submitted: 2011-07-29 21:07 UTC Modified: 2015-06-10 19:57 UTC
Votes:2
Avg. Score:3.0 ± 2.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: todesw1nd at hotmail dot com Assigned: cmb (profile)
Status: Closed Package: *General Issues
PHP Version: 5.3.7RC3 OS: Windows 7 Professional SP 1
Private report: No CVE-ID: None
 [2011-07-29 21:07 UTC] todesw1nd at hotmail dot com
Description:
------------
using the php_uname function with e.g. the 'v' flag gives a description that does not exactly match the operating system installed.

this is a very minor thing, but i think i might report it ;)

ps: i don't know if that's important, but its a standard x86_64 edition of win7 with service pack 1 installed as already mentioned above.

Test script:
---------------
echo php_uname('v');

Expected result:
----------------
build 7601 (Windows 7 Professional Service Pack 1)

Actual result:
--------------
build 7601 (Unknow Windows version Business Edition Service Pack 1)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-07-29 21:30 UTC] todesw1nd at hotmail dot com
-PHP Version: 5.3.7RC4 +PHP Version: 5.3.7RC3
 [2011-07-29 21:30 UTC] todesw1nd at hotmail dot com
selected the wrong version, tested with rc3. new rc4 calls it "build 7601 (Windows 7 Business Edition Service Pack 1)" but it should be "build 7601 (Windows 7 Professional Service Pack 1)"
 [2011-07-29 23:41 UTC] pajoye@php.net
-Status: Open +Status: Feedback
 [2011-07-29 23:41 UTC] pajoye@php.net
Please try using this snapshot:

  http://snaps.php.net/php5.4-latest.tar.gz
 
For Windows:

  http://windows.php.net/snapshots/


 [2011-07-30 00:32 UTC] todesw1nd at hotmail dot com
-Status: Feedback +Status: Open
 [2011-07-30 00:32 UTC] todesw1nd at hotmail dot com
"PHP Version 5.4.0alpha3-dev" and "PHP Version 5.3.7RC4" both say its "build 7601 (Windows 7 Business Edition Service Pack 1)" whilst "PHP Version 5.3.7RC3" and earlier versions called it "build 7601 (Unknow Windows version Business Edition Service Pack 1)" and like i already said it should be something like Windows Professional as it is the standard professional edition.
 [2011-07-30 11:28 UTC] pajoye@php.net
-Status: Open +Status: Feedback
 [2011-07-30 11:28 UTC] pajoye@php.net
The detection code is correct, as in it uses the windows function with the correct 
checks.

Can you paste here what you see on the computer properties dialog please? It could 
be either a bug or a an alias issue in the GetProductInfo API.
 [2011-07-30 11:46 UTC] todesw1nd at hotmail dot com
-Status: Feedback +Status: Open
 [2011-07-30 11:46 UTC] todesw1nd at hotmail dot com
Windows 7 Professional
Copyright (c) 2009 Microsoft Corporation. All rights reserved.
Service Pack 1
 [2015-06-05 14:59 UTC] cmb@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2015-06-05 14:59 UTC] cmb@php.net
Please try the snapshots linked from bug #69642:
<http://windows.php.net/downloads/snaps/ostc/69642/manifest_test.zip>.
 [2015-06-08 15:03 UTC] wenz@php.net
the patch from bug #69642 correctly identifies 7.1, but does not change the detection of the SKU names, but I have prepared a patch that fixes this bug (and two more scenarios with incorrect behavior) and will reference the associated bug report once I am done with it, probably tomorrow.
 [2015-06-10 19:57 UTC] ab@php.net
-Status: Feedback +Status: Closed
 [2015-06-10 19:57 UTC] ab@php.net
This should be now fixed by the patch from the bug #69781. By the current info this one is considered as a sub case.

Thanks.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Sep 16 07:01:26 2019 UTC