php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #54020 build 7600
Submitted: 2011-02-14 19:17 UTC Modified: 2015-03-29 04:27 UTC
Votes:14
Avg. Score:4.6 ± 0.8
Reproduced:13 of 13 (100.0%)
Same Version:11 (84.6%)
Same OS:13 (100.0%)
From: hankmanw7 at home dot nl Assigned: kalle (profile)
Status: Closed Package: *General Issues
PHP Version: 5.3.5 OS: Windows 7 Professional
Private report: No CVE-ID: None
 [2011-02-14 19:17 UTC] hankmanw7 at home dot nl
Description:
------------
Php echoes incorrect information about the OS

Test script:
---------------
Running on Windows 7 Professional edition:
 
$build = php_uname('v');  /* Version information */
echo $build;

Results in:
build 7600 (Unknow Windows version Business Edition)



Expected result:
----------------
build 7600 (Windows 7 Professional Edition)

Actual result:
--------------
build 7600 (Unknow Windows version Business Edition)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-02-15 11:27 UTC] kalle@php.net
-Status: Open +Status: Assigned
 [2011-02-15 11:27 UTC] kalle@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: kalle
 [2011-02-18 11:49 UTC] hankmanw7 at home dot nl
Windows 7 Professional has Service Pack 1 installed:

Expected result should be: build 7601 (Windows 7 Professional Edition Service Pack 1)
 [2015-03-29 04:27 UTC] kalle@php.net
-Status: Assigned +Status: Closed
 [2015-06-09 08:02 UTC] wenz@php.net
IMHO this was closed too early, since the Professional Edition of Windows 7 is still reported as "Business" edition. Bug #55319 shows a similar report. I have created Bug #69781 with the more generic issue, and a fix.
 [2015-06-10 10:10 UTC] wenz@php.net
Bug #69781 has been closed, so this is now correctly closed, as well.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Jul 26 17:01:23 2021 UTC