php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #55294 DOMDocument::importNode shifts namespaces when "default" namespace exists
Submitted: 2011-07-27 12:35 UTC Modified: 2013-12-02 19:40 UTC
Votes:6
Avg. Score:4.8 ± 0.4
Reproduced:4 of 4 (100.0%)
Same Version:1 (25.0%)
Same OS:2 (50.0%)
From: hilse at web dot de Assigned:
Status: Not a bug Package: DOM XML related
PHP Version: trunk-SVN-2011-07-27 (snap) OS: Linux
Private report: No CVE-ID: None
 [2011-07-27 12:35 UTC] hilse at web dot de
Description:
------------
When importing nodes and their children via DOMDocument::importNode, the method 
will introduce the "default" namespace prefix. Herein lies a bug that will trigger 
if the namespace prefix "default" is already assigned (even if not applied to any 
element) within the children of the imported node.

Test script:
---------------
<?php
$aDOM=DOMDocument::loadXML(<<<EOXML
<A xmlns="http://example.hilses.de/A">
	<B>
		<C
			xmlns="http://example.hilses.de/C"
			xmlns:default="http://example.hilses.de/Z" />
	</B>
</A>
EOXML
);

$bDOM=new DOMDocument();
$node = $bDOM->importNode($aDOM->getElementsByTagNameNS('http://example.hilses.de/A','B')->item(0), true);
$bDOM->appendChild($node);

echo $bDOM->saveXML()."\n";
?>

Expected result:
----------------
<?xml version="1.0"?>
<B xmlns="http://example.hilses.de/A" xmlns:default="http://example.hilses.de/C">
		<default:C />
</B>

or even better:

<?xml version="1.0"?>
<B xmlns="http://example.hilses.de/A">
		<C xmlns="http://example.hilses.de/C"/>
</B>

Actual result:
--------------
<?xml version="1.0"?>
<B xmlns="http://example.hilses.de/A" xmlns:default="http://example.hilses.de/C">
	<default:C xmlns="http://example.hilses.de/C" 
xmlns:default="http://example.hilses.de/Z"/>
</B>


(see how C is put into the ".../Z" namespace now instead of ".../C", since 
namespace prefix declarations are valid for the element in which they are 
defined!)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-12-02 19:40 UTC] mike@php.net
-Status: Open +Status: Not a bug
 [2013-12-02 19:40 UTC] mike@php.net
If, then an upstream bug of libxml2.

xmlNewReconciliedNS() uses "default" as prefix if not already found in the doc.

So either don't use default, or looking at libxml2 sources, default followed by a number in the range 0-1000, or file a bug at http://bugzilla.gnome.org/buglist.cgi?product=libxml2

And on a side note: it happens on append not import.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 01 10:03:34 2021 UTC