php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #54789 Missing default value in prototype of xmlwriter_flush()
Submitted: 2011-05-17 12:22 UTC Modified: 2011-05-19 14:35 UTC
From: gwarnants at gmail dot com Assigned: salathe
Status: Closed Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID:
 [2011-05-17 12:22 UTC] gwarnants at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/function.xmlwriter-flush#Description
---

According to parameters description it seems default value for parameter
$empty is missing in the procedural and oop prototypes, although textual
description says its default value is TRUE. So it could be added in both
prototype.

Regards,
Geoffray

Expected result:
----------------
mixed XMLWriter::flush ([ bool $empty = true ] )
mixed xmlwriter_flush ( resource $xmlwriter [, bool $empty = true ] )

Actual result:
--------------
mixed XMLWriter::flush ([ bool $empty ] )
mixed xmlwriter_flush ( resource $xmlwriter [, bool $empty ] )

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-05-19 14:35 UTC] salathe@php.net
Automatic comment from SVN on behalf of salathe
Revision: http://svn.php.net/viewvc/?view=revision&revision=311248
Log: initializer for xmlwriter outputmemory/flush (doc #54788)
 [2011-05-19 14:35 UTC] salathe@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: salathe
 [2011-05-19 14:35 UTC] salathe@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Fri Jul 28 08:01:47 2017 UTC