php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #54788 Missing default value in prototype of xmlwriter_output_memory()
Submitted: 2011-05-17 12:19 UTC Modified: 2011-05-19 14:34 UTC
From: gwarnants at gmail dot com Assigned: salathe (profile)
Status: Closed Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2011-05-17 12:19 UTC] gwarnants at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/function.xmlwriter-output-memory#Description
---

According to parameters description it seems default value for parameter $flush is missing in the procedural and oop prototypes, although textual description says its default value is TRUE. So it could be added in both prototype.

Regards,
Geoffray

Expected result:
----------------
string XMLWriter::outputMemory ([ bool $flush = true ] )
string xmlwriter_output_memory ( resource $xmlwriter [, bool $flush = true ] )

Actual result:
--------------
string XMLWriter::outputMemory ([ bool $flush ] )
string xmlwriter_output_memory ( resource $xmlwriter [, bool $flush ] )

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-05-19 14:34 UTC] salathe@php.net
Automatic comment from SVN on behalf of salathe
Revision: http://svn.php.net/viewvc/?view=revision&revision=311248
Log: initializer for xmlwriter outputmemory/flush (doc #54788)
 [2011-05-19 14:34 UTC] salathe@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: salathe
 [2011-05-19 14:34 UTC] salathe@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sat Nov 18 08:03:32 2017 UTC