php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #53255 "Incorrect CAPTCHA" trying to file a bug report
Submitted: 2010-11-07 19:24 UTC Modified: 2019-01-07 11:09 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:1 (50.0%)
From: chealer at gmail dot com Assigned: cmb (profile)
Status: Duplicate Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2010-11-07 19:24 UTC] chealer at gmail dot com
Description:
------------
When filing a bug report, bugs.php.net [almost] always asks:


Are you sure that you searched before you submitted your bug report? We found the following bugs that seem to be similar to yours; please check them before sumitting the report as they might contain the solution you are looking for.

If you're sure that your report is a genuine bug that has not been reported before, you can scroll down and click the submit button to really enter the details into our database.


Clicking the submit button fails with:


ERROR:

    * Incorrect Captcha


even if the captcha was correct (this happened to me at least 5 times). Then one can solve another captcha, re-submit and the report will be actually filed.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-12-27 01:26 UTC] bjori@php.net
-Status: Open +Status: Not a bug
 [2013-12-27 01:26 UTC] bjori@php.net
We get this reports 1-2 a year. Has always been PEBCAK
 [2013-12-27 23:17 UTC] chealer at gmail dot com
bjori, could you explain how this wouldn't constitute a bug?
 [2013-12-28 07:47 UTC] bjori@php.net
Because you didn't answer capatcha correctly.
You may think you did, but you didn't.
 [2013-12-28 20:32 UTC] chealer at gmail dot com
I see... could you explain how you reached that conclusion?
 [2013-12-30 02:25 UTC] danielc@php.net
Because a recent ticket ID is 66366 and your ticket ID is 53255.  That means that since this ticket was opened, 13111 people have successfully entered their CAPTCHAs.
 [2013-12-30 03:00 UTC] chealer at gmail dot com
In fact, that only means that one or more people have managed to open a total of 13111 tickets or more. Notice that yours truly himself managed to open tickets despite this bug, as this very ticket exemplifies. As you will notice if you read the description properly, there is a way to workaround, which [almost] everyone must be using to manage to open tickets.

Thanks, but if you don't mind, I don't think speculation is needed. I'm sure bjori is a grown-up able to justify his actions by himself.
 [2013-12-30 03:29 UTC] bjori@php.net
-Block user comment: No +Block user comment: Yes
 [2013-12-30 03:33 UTC] bjori@php.net
Your math isn't as good as you think.
I just filed https://bugs.php.net/bug.php?id=66367 without getting any errors.
 [2019-01-07 01:48 UTC] kalle@php.net
-Status: Not a bug +Status: Re-Opened
 [2019-01-07 02:44 UTC] chealer at gmail dot com
This is now tracked in ticket #66653. This ticket could be marked as a duplicate (although technically the reality is opposite).

bjori, I recommend you to see that ticket.
 [2019-01-07 11:09 UTC] cmb@php.net
-Status: Re-Opened +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2019-01-07 11:09 UTC] cmb@php.net
Marking as duplicate of bug #66653 as suggested by the OP.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Apr 21 04:01:25 2019 UTC