php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #53114 Assertion failed exited on signal 6 SIGABRT
Submitted: 2010-10-20 13:59 UTC Modified: 2010-11-11 18:13 UTC
From: 102956 at mail dot ru Assigned: fat (profile)
Status: Not a bug Package: FPM related
PHP Version: 5.3.3 OS: FreeBSD 7.3
Private report: No CVE-ID: None
 [2010-10-20 13:59 UTC] 102956 at mail dot ru
Description:
------------
Good afternoon.
I use sheaf Nginx-Php 5.3.3 with FPM
Each site works from the user.
On a hosting the server, periodically there are problems. Process php-fpm which belongs to the root user, I so understand it parent process, starts to occupy many random access memory, the order of 400-500 Mbytes and so absorbs processor time, the order of 90 %. 
In a log files thus the following:
- -
Oct 20 09:16:30.523767 [WARNING] [pool carobka] child 93353, script 

'/home/carobka/domains/carobka.ru/public_html/mov_conv.php ' execution tim
ed out (120.024054 sec), terminating
Oct 20 09:16:30.525500 [WARNING] [pool carobka] child 93353 exited on signal 15 SIGTERM after 835.521378 seconds 

from start
Oct 20 09:16:30.527112 [NOTICE] [pool carobka] child 93502 started
Oct 20 09:16:30.529921 [WARNING] [pool carobka] child 93502 said into stderr: "Assertion failed: 

(TAILQ_EMPTY (&base-> eventqueue)), function e
vent_base_free, file event.c, line 268."
Oct 20 09:16:30.531324 [WARNING] [pool carobka] child 93502 exited on signal 6 SIGABRT after 0.004412 seconds 

from start
- -

After I reboot php-fpm all comes to the order and any time can continue to work still. 
I also have received core a file when I have tried to look with the help gdb I have seen: Core was generated by ` php-fpm '.
Program terminated with signal 6, Aborted.
#0 0x28686e17 in?? ()

And more than any helpful information.


I so have read http://bugs.php.net/52501 and I have seen that a problem similar, but I don't use sendmail, my scripts use SMTP sockets. I have applied patch: fpm-nomorelibevent.v8.patch, some time I suffered so that all points were success, as a result I managed to install php but when I have launched again php-fpm in a log files I has seen the following:

Oct 20 15:10:57.532823 [WARNING] [pool arriva.arriva.ru] child 21040 said into stderr: "Out of memory"
Oct 20 15:10:57.876799 [WARNING] [pool arriva.arriva.ru] child 21041 said into stderr: "Out of memory"
Oct 20 15:10:57.934929 [WARNING] [pool arriva.arriva.ru] child 21042 said into stderr: "Out of memory"
Oct 20 15:10:58.101454 [WARNING] [pool carobka] child 21060 said into stderr: "Out of memory"
Oct 20 15:10:58.111586 [WARNING] [pool arriva.arriva.ru] child 21043 said into stderr: "Out of memory"
Oct 20 15:10:58.183676 [WARNING] [pool arriva.arriva.ru] child 21044 said into stderr: "Out of memory"
Oct 20 15:10:58.532873 [WARNING] [pool carobka] child 21061 said into stderr: "Out of memory"
Oct 20 15:10:58.746227 [WARNING] [pool arriva.arriva.ru] child 21045 said into stderr: "Out of memory"
Oct 20 15:10:58.823848 [WARNING] [pool carobka] child 21062 said into stderr: "Out of memory"
Oct 20 15:10:59.476761 [WARNING] [pool arriva.arriva.ru] child 21046 said into stderr: "Out of memory"
Oct 20 15:10:59.538260 [WARNING] [pool arriva.arriva.ru] child 21047 said into stderr: "Out of memory"
Oct 20 15:10:59.609409 [WARNING] [pool carobka] child 21063 said into stderr: "Out of memory"
Oct 20 15:11:00.198145 [WARNING] [pool arriva.arriva.ru] child 21049 said into stderr: "Out of memory"
Oct 20 15:11:00.317165 [WARNING] [pool arriva.arriva.ru] child 21050 said into stderr: "Out of memory"
Oct 20 15:11:00.549732 [WARNING] [pool carobka] child 21064 said into stderr: "Out of memory"
Oct 20 15:11:00.938892 [WARNING] [pool arriva.arriva.ru] child 21051 said into stderr: "Out of memory"
Oct 20 15:11:00.952763 [WARNING] [pool carobka] child 21065 said into stderr: "Out of memory"
Oct 20 15:11:01.007574 [WARNING] [pool carobka] child 21066 said into stderr: "Out of memory"
Oct 20 15:11:01.919207 [WARNING] [pool arriva.arriva.ru] child 21052 said into stderr: "Out of memory"
Oct 20 15:11:02.918834 [WARNING] [pool carobka] child 21067 said into stderr: "Out of memory"
Oct 20 15:11:03.159053 [WARNING] [pool arriva.arriva.ru] child 21054 said into stderr: "Out of memory"
Oct 20 15:11:03.289054 [WARNING] [pool carobka] child 21068 said into stderr: "Out of memory"
Oct 20 15:11:03.835604 [WARNING] [pool carobka] child 21069 said into stderr: "Out of memory"
----
Here my configuration file:

include=/usr/local/etc/fpm.d/*.conf

;;;;;;;;;;;;;;;;;;
; Global Options ;
;;;;;;;;;;;;;;;;;;

[global]
pid = /var/run/php-fpm.pid
error_log = /var/log/php-fpm.log
log_level = notice
emergency_restart_threshold = 10
emergency_restart_interval = 1m
process_control_timeout = 10s
daemonize = yes


;;;;;;;;;;;;;;;;;;;;
; Pool Definitions ;
;;;;;;;;;;;;;;;;;;;;


[arriva.arriva.ru]

listen = /home/arriva/arriva.arriva.ru.php.sock
listen.backlog = -1
listen.owner = arriva
listen.group = apache
listen.mode = 0666
user = arriva
group = arriva

pm = dynamic
pm.max_children = 128
pm.start_servers = 20
pm.min_spare_servers = 15
pm.max_spare_servers = 30
pm.max_requests = 500
pm.status_path = /status
request_terminate_timeout = 120s
rlimit_files = 206103
rlimit_core = 0
catch_workers_output = yes
env[HOSTNAME] = arriva.ru
env[PATH] = /usr/local/bin:/usr/bin:/bin
env[TMP] = /home/arriva/tmp
env[TMPDIR] = /home/arriva/tmp
env[TEMP] = /home/arriva/tmp

;php_flag[display_errors] = off
php_admin_value[error_log] = /var/log/fpm-php.wwwarriva.ru.log
php_admin_flag[log_errors] = on
php_admin_value[memory_limit] = 256M



How to me to rectify errors which I has described above? 
Thanks


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-10-20 14:36 UTC] fat@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: fat
 [2010-10-20 14:36 UTC] fat@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.


This should be the same problem as bug 52501 (http://bugs.php.net/bug.php?
id=52501).

Can you test the patch attached to the bug report 52501 please ?

Does the script mov_conv.php call an external program ? (like 
/usr/local/bin/ffmpeg)
 [2010-10-20 15:29 UTC] 102956 at mail dot ru
-Status: Feedback +Status: Assigned
 [2010-10-20 15:29 UTC] 102956 at mail dot ru
Here there is some information from log a file, the script add.php - adds the text and photos when has effused timeout in 60 s php where killed by process and further as we see errors begin.
---
Oct 18 08:41:10.488290 [WARNING] [pool carobka] child 4434, script '/home/carobka/domains/carobka.ru/public_html/bu/add.php'
execution timed out (60.081447 sec), terminating
Oct 18 08:41:10.490216 [WARNING] [pool carobka] child 4434 exited on signal 15 SIGTERM after 67.571231 seconds from start
Oct 18 08:41:10.492218 [NOTICE] [pool carobka] child 4459 started
Oct 18 08:41:10.495778 [WARNING] [pool carobka] child 4459 said into stderr: "Assertion failed: (TAILQ_EMPTY(&base->eventqueu
e)), function event_base_free, file event.c, line 268."
Oct 18 08:41:10.497352 [WARNING] [pool carobka] child 4459 exited on signal 6 SIGABRT after 0.005312 seconds from start
Oct 18 08:41:10.499910 [NOTICE] [pool carobka] child 4461 started
Oct 18 08:41:10.502994 [WARNING] [pool carobka] child 4461 said into stderr: "Assertion failed: (TAILQ_EMPTY(&base->eventqueu
e)), function event_base_free, file event.c, line 268."
Oct 18 08:41:10.504435 [WARNING] [pool carobka] child 4461 exited on signal 6 SIGABRT after 0.004854 seconds from start
Oct 18 08:41:10.506161 [NOTICE] [pool carobka] child 4463 started
Oct 18 08:41:10.508313 [WARNING] [pool carobka] child 4463 said into stderr: "Assertion failed: (TAILQ_EMPTY(&base->eventqueu
e)), function event_base_free, file event.c, line 268."
Oct 18 08:41:10.509665 [WARNING] [pool carobka] child 4463 exited on signal 6 SIGABRT after 0.003668 seconds from start
Oct 18 08:41:10.511507 [NOTICE] [pool carobka] child 4464 started
Oct 18 08:41:10.513880 [WARNING] [pool carobka] child 4464 said into stderr: "Assertion failed: (TAILQ_EMPTY(&base->eventqueu
e)), function event_base_free, file event.c, line 268."
Oct 18 08:41:10.515247 [WARNING] [pool carobka] child 4464 exited on signal 6 SIGABRT after 0.003920 seconds from start
Oct 18 08:41:10.516971 [NOTICE] [pool carobka] child 4465 started
Oct 18 08:41:10.519224 [WARNING] [pool carobka] child 4465 said into stderr: "Assertion failed: (TAILQ_EMPTY(&base->eventqueu
e)), function event_base_free, file event.c, line 268."
---

PHP config:

./configure --with-layout=GNU --localstatedir=/var --with-config-file-scan-dir=/usr/local/etc/php --disable-all --enable-libxml --with-libxml-dir=/usr/local --with-pcre-regex=/usr/local --with-zlib-dir=/usr --program-prefix= --enable-fpm --with-fpm-user=www --with-fpm-group=www --with-libevent-dir=/usr/local --with-regex=php --with-zend-vm=CALL --enable-zend-multibyte --disable-ipv6 --prefix=/usr/local --mandir=/usr/local/man --infodir=/usr/local/info/ --build=i386-portbld-freebsd7.3

Dynamic extensions:

php -v
PHP 5.3.3 with Suhosin-Patch (cli) (built: Oct 20 2010 15:17:37)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
earth# php -m
[PHP Modules]
bz2
Core
ctype
curl
date
dom
ereg
filter
gd
hash
iconv
json
libxml
mbstring
mcrypt
mhash
mysql
mysqli
mysqlnd
pcre
posix
Reflection
session
shmop
SimpleXML
sockets
SPL
standard
timezonedb
tokenizer
xml
xmlreader
xmlrpc
xmlwriter
zlib

[Zend Modules]


I have tried to use patch from bug report 52501, but not all stages were completed successfully, here a broad gull:

patch < fpm-nomorelibevent.v8.patch
Hmm...  Looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: sapi/fpm/fpm/fpm_children.h
|===================================================================
|--- sapi/fpm/fpm/fpm_children.h        (rйvision 303306)
|+++ sapi/fpm/fpm/fpm_children.h        (copie de travail)
--------------------------
Patching file sapi/fpm/fpm/fpm_children.h using Plan A...
Hunk #1 succeeded at 7.
Hunk #2 succeeded at 23.
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: sapi/fpm/fpm/fpm_process_ctl.c
|===================================================================
|--- sapi/fpm/fpm/fpm_process_ctl.c     (rйvision 303306)
|+++ sapi/fpm/fpm/fpm_process_ctl.c     (copie de travail)
--------------------------
Patching file sapi/fpm/fpm/fpm_process_ctl.c using Plan A...
Hunk #1 succeeded at 48.
Hunk #2 succeeded at 144.
Hunk #3 succeeded at 168.
Hunk #4 succeeded at 194.
Hunk #5 succeeded at 230.
Hunk #6 succeeded at 246.
Hunk #7 succeeded at 305 with fuzz 1.
Hunk #8 failed at 385.
Hunk #9 succeeded at 405 (offset -2 lines).
Hunk #10 succeeded at 447 (offset -2 lines).
1 out of 10 hunks failed--saving rejects to sapi/fpm/fpm/fpm_process_ctl.c.rej
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: sapi/fpm/fpm/fpm.c
|===================================================================
|--- sapi/fpm/fpm/fpm.c (rйvision 303306)
|+++ sapi/fpm/fpm/fpm.c (copie de travail)
--------------------------
Patching file sapi/fpm/fpm/fpm.c using Plan A...
Hunk #1 succeeded at 23.
Hunk #2 succeeded at 39.
Hunk #3 succeeded at 55.
Hunk #4 succeeded at 63.
Hunk #5 succeeded at 71.
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: sapi/fpm/fpm/fpm_stdio.c
|===================================================================
|--- sapi/fpm/fpm/fpm_stdio.c   (rйvision 303306)
|+++ sapi/fpm/fpm/fpm_stdio.c   (copie de travail)
--------------------------
Patching file sapi/fpm/fpm/fpm_stdio.c using Plan A...
Hunk #1 succeeded at 72.
Hunk #2 succeeded at 109.
Hunk #3 succeeded at 196.
Hunk #4 succeeded at 208.
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: sapi/fpm/fpm/fpm_process_ctl.h
|===================================================================
|--- sapi/fpm/fpm/fpm_process_ctl.h     (rйvision 303306)
|+++ sapi/fpm/fpm/fpm_process_ctl.h     (copie de travail)
--------------------------
Patching file sapi/fpm/fpm/fpm_process_ctl.h using Plan A...
Hunk #1 succeeded at 5.
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: sapi/fpm/fpm/fpm.h
|===================================================================
|--- sapi/fpm/fpm/fpm.h (rйvision 303306)
|+++ sapi/fpm/fpm/fpm.h (copie de travail)
--------------------------
Patching file sapi/fpm/fpm/fpm.h using Plan A...
Hunk #1 succeeded at 6.
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: sapi/fpm/fpm/fpm_stdio.h
|===================================================================
|--- sapi/fpm/fpm/fpm_stdio.h   (rйvision 303306)
|+++ sapi/fpm/fpm/fpm_stdio.h   (copie de travail)
--------------------------
Patching file sapi/fpm/fpm/fpm_stdio.h using Plan A...
Hunk #1 succeeded at 12.
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: sapi/fpm/fpm/fpm_events.c
|===================================================================
|--- sapi/fpm/fpm/fpm_events.c  (rйvision 303306)
|+++ sapi/fpm/fpm/fpm_events.c  (copie de travail)
--------------------------
Patching file sapi/fpm/fpm/fpm_events.c using Plan A...
Hunk #1 succeeded at 9.
Hunk #2 succeeded at 20.
Hunk #3 succeeded at 69.
Hunk #4 succeeded at 97.
Hunk #5 failed at 109.
1 out of 5 hunks failed--saving rejects to sapi/fpm/fpm/fpm_events.c.rej
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: sapi/fpm/fpm/fpm_events.h
|===================================================================
|--- sapi/fpm/fpm/fpm_events.h  (rйvision 303306)
|+++ sapi/fpm/fpm/fpm_events.h  (copie de travail)
--------------------------
Patching file sapi/fpm/fpm/fpm_events.h using Plan A...
Hunk #1 succeeded at 5.
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: sapi/fpm/fpm/fpm_main.c
|===================================================================
|--- sapi/fpm/fpm/fpm_main.c    (rйvision 303306)
|+++ sapi/fpm/fpm/fpm_main.c    (copie de travail)
--------------------------
Patching file sapi/fpm/fpm/fpm_main.c using Plan A...
Hunk #1 succeeded at 166.
Hunk #2 succeeded at 1762 (offset 1 line).
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: sapi/fpm/fpm/fpm_children.c
|===================================================================
|--- sapi/fpm/fpm/fpm_children.c        (rйvision 303306)
|+++ sapi/fpm/fpm/fpm_children.c        (copie de travail)
--------------------------
Patching file sapi/fpm/fpm/fpm_children.c using Plan A...
Hunk #1 succeeded at 171.
Hunk #2 succeeded at 277.
Hunk #3 succeeded at 340.
Hunk #4 succeeded at 378.
Hunk #5 succeeded at 394.
Hunk #6 succeeded at 405.
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: sapi/fpm/config.m4
|===================================================================
|--- sapi/fpm/config.m4 (rйvision 303306)
|+++ sapi/fpm/config.m4 (copie de travail)
--------------------------
Patching file sapi/fpm/config.m4 using Plan A...
Hunk #1 failed at 2.
Hunk #2 failed at 311.
Hunk #3 succeeded at 333 (offset -23 lines).
2 out of 3 hunks failed--saving rejects to sapi/fpm/config.m4.rej
done
---
Does the script mov_conv.php call an external program ? (like 
/usr/local/bin/ffmpeg) - Yes


What else information has enough?
 [2010-10-20 15:31 UTC] 102956 at mail dot ru
-Status: Assigned +Status: Open
 [2010-10-20 15:31 UTC] 102956 at mail dot ru
Here there is some information from log a file, the script add.php - adds the text and photos when has effused timeout in 60 s php where killed by process and further as we see errors begin.
---
Oct 18 08:41:10.488290 [WARNING] [pool carobka] child 4434, script '/home/carobka/domains/carobka.ru/public_html/bu/add.php'
execution timed out (60.081447 sec), terminating
Oct 18 08:41:10.490216 [WARNING] [pool carobka] child 4434 exited on signal 15 SIGTERM after 67.571231 seconds from start
Oct 18 08:41:10.492218 [NOTICE] [pool carobka] child 4459 started
Oct 18 08:41:10.495778 [WARNING] [pool carobka] child 4459 said into stderr: "Assertion failed: (TAILQ_EMPTY(&base->eventqueu
e)), function event_base_free, file event.c, line 268."
Oct 18 08:41:10.497352 [WARNING] [pool carobka] child 4459 exited on signal 6 SIGABRT after 0.005312 seconds from start
Oct 18 08:41:10.499910 [NOTICE] [pool carobka] child 4461 started
Oct 18 08:41:10.502994 [WARNING] [pool carobka] child 4461 said into stderr: "Assertion failed: (TAILQ_EMPTY(&base->eventqueu
e)), function event_base_free, file event.c, line 268."
Oct 18 08:41:10.504435 [WARNING] [pool carobka] child 4461 exited on signal 6 SIGABRT after 0.004854 seconds from start
Oct 18 08:41:10.506161 [NOTICE] [pool carobka] child 4463 started
Oct 18 08:41:10.508313 [WARNING] [pool carobka] child 4463 said into stderr: "Assertion failed: (TAILQ_EMPTY(&base->eventqueu
e)), function event_base_free, file event.c, line 268."
Oct 18 08:41:10.509665 [WARNING] [pool carobka] child 4463 exited on signal 6 SIGABRT after 0.003668 seconds from start
Oct 18 08:41:10.511507 [NOTICE] [pool carobka] child 4464 started
Oct 18 08:41:10.513880 [WARNING] [pool carobka] child 4464 said into stderr: "Assertion failed: (TAILQ_EMPTY(&base->eventqueu
e)), function event_base_free, file event.c, line 268."
Oct 18 08:41:10.515247 [WARNING] [pool carobka] child 4464 exited on signal 6 SIGABRT after 0.003920 seconds from start
Oct 18 08:41:10.516971 [NOTICE] [pool carobka] child 4465 started
Oct 18 08:41:10.519224 [WARNING] [pool carobka] child 4465 said into stderr: "Assertion failed: (TAILQ_EMPTY(&base->eventqueu
e)), function event_base_free, file event.c, line 268."
---

PHP config:

./configure --with-layout=GNU --localstatedir=/var --with-config-file-scan-dir=/usr/local/etc/php --disable-all --enable-libxml --with-libxml-dir=/usr/local --with-pcre-regex=/usr/local --with-zlib-dir=/usr --program-prefix= --enable-fpm --with-fpm-user=www --with-fpm-group=www --with-libevent-dir=/usr/local --with-regex=php --with-zend-vm=CALL --enable-zend-multibyte --disable-ipv6 --prefix=/usr/local --mandir=/usr/local/man --infodir=/usr/local/info/ --build=i386-portbld-freebsd7.3

Dynamic extensions:

php -v
PHP 5.3.3 with Suhosin-Patch (cli) (built: Oct 20 2010 15:17:37)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
earth# php -m
[PHP Modules]
bz2
Core
ctype
curl
date
dom
ereg
filter
gd
hash
iconv
json
libxml
mbstring
mcrypt
mhash
mysql
mysqli
mysqlnd
pcre
posix
Reflection
session
shmop
SimpleXML
sockets
SPL
standard
timezonedb
tokenizer
xml
xmlreader
xmlrpc
xmlwriter
zlib

[Zend Modules]


I have tried to use patch from bug report 52501, but not all stages were completed successfully, here a broad gull:

patch < fpm-nomorelibevent.v8.patch
Hmm...  Looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: sapi/fpm/fpm/fpm_children.h
|===================================================================
|--- sapi/fpm/fpm/fpm_children.h        (rйvision 303306)
|+++ sapi/fpm/fpm/fpm_children.h        (copie de travail)
--------------------------
Patching file sapi/fpm/fpm/fpm_children.h using Plan A...
Hunk #1 succeeded at 7.
Hunk #2 succeeded at 23.
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: sapi/fpm/fpm/fpm_process_ctl.c
|===================================================================
|--- sapi/fpm/fpm/fpm_process_ctl.c     (rйvision 303306)
|+++ sapi/fpm/fpm/fpm_process_ctl.c     (copie de travail)
--------------------------
Patching file sapi/fpm/fpm/fpm_process_ctl.c using Plan A...
Hunk #1 succeeded at 48.
Hunk #2 succeeded at 144.
Hunk #3 succeeded at 168.
Hunk #4 succeeded at 194.
Hunk #5 succeeded at 230.
Hunk #6 succeeded at 246.
Hunk #7 succeeded at 305 with fuzz 1.
Hunk #8 failed at 385.
Hunk #9 succeeded at 405 (offset -2 lines).
Hunk #10 succeeded at 447 (offset -2 lines).
1 out of 10 hunks failed--saving rejects to sapi/fpm/fpm/fpm_process_ctl.c.rej
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: sapi/fpm/fpm/fpm.c
|===================================================================
|--- sapi/fpm/fpm/fpm.c (rйvision 303306)
|+++ sapi/fpm/fpm/fpm.c (copie de travail)
--------------------------
Patching file sapi/fpm/fpm/fpm.c using Plan A...
Hunk #1 succeeded at 23.
Hunk #2 succeeded at 39.
Hunk #3 succeeded at 55.
Hunk #4 succeeded at 63.
Hunk #5 succeeded at 71.
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: sapi/fpm/fpm/fpm_stdio.c
|===================================================================
|--- sapi/fpm/fpm/fpm_stdio.c   (rйvision 303306)
|+++ sapi/fpm/fpm/fpm_stdio.c   (copie de travail)
--------------------------
Patching file sapi/fpm/fpm/fpm_stdio.c using Plan A...
Hunk #1 succeeded at 72.
Hunk #2 succeeded at 109.
Hunk #3 succeeded at 196.
Hunk #4 succeeded at 208.
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: sapi/fpm/fpm/fpm_process_ctl.h
|===================================================================
|--- sapi/fpm/fpm/fpm_process_ctl.h     (rйvision 303306)
|+++ sapi/fpm/fpm/fpm_process_ctl.h     (copie de travail)
--------------------------
Patching file sapi/fpm/fpm/fpm_process_ctl.h using Plan A...
Hunk #1 succeeded at 5.
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: sapi/fpm/fpm/fpm.h
|===================================================================
|--- sapi/fpm/fpm/fpm.h (rйvision 303306)
|+++ sapi/fpm/fpm/fpm.h (copie de travail)
--------------------------
Patching file sapi/fpm/fpm/fpm.h using Plan A...
Hunk #1 succeeded at 6.
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: sapi/fpm/fpm/fpm_stdio.h
|===================================================================
|--- sapi/fpm/fpm/fpm_stdio.h   (rйvision 303306)
|+++ sapi/fpm/fpm/fpm_stdio.h   (copie de travail)
--------------------------
Patching file sapi/fpm/fpm/fpm_stdio.h using Plan A...
Hunk #1 succeeded at 12.
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: sapi/fpm/fpm/fpm_events.c
|===================================================================
|--- sapi/fpm/fpm/fpm_events.c  (rйvision 303306)
|+++ sapi/fpm/fpm/fpm_events.c  (copie de travail)
--------------------------
Patching file sapi/fpm/fpm/fpm_events.c using Plan A...
Hunk #1 succeeded at 9.
Hunk #2 succeeded at 20.
Hunk #3 succeeded at 69.
Hunk #4 succeeded at 97.
Hunk #5 failed at 109.
1 out of 5 hunks failed--saving rejects to sapi/fpm/fpm/fpm_events.c.rej
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: sapi/fpm/fpm/fpm_events.h
|===================================================================
|--- sapi/fpm/fpm/fpm_events.h  (rйvision 303306)
|+++ sapi/fpm/fpm/fpm_events.h  (copie de travail)
--------------------------
Patching file sapi/fpm/fpm/fpm_events.h using Plan A...
Hunk #1 succeeded at 5.
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: sapi/fpm/fpm/fpm_main.c
|===================================================================
|--- sapi/fpm/fpm/fpm_main.c    (rйvision 303306)
|+++ sapi/fpm/fpm/fpm_main.c    (copie de travail)
--------------------------
Patching file sapi/fpm/fpm/fpm_main.c using Plan A...
Hunk #1 succeeded at 166.
Hunk #2 succeeded at 1762 (offset 1 line).
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: sapi/fpm/fpm/fpm_children.c
|===================================================================
|--- sapi/fpm/fpm/fpm_children.c        (rйvision 303306)
|+++ sapi/fpm/fpm/fpm_children.c        (copie de travail)
--------------------------
Patching file sapi/fpm/fpm/fpm_children.c using Plan A...
Hunk #1 succeeded at 171.
Hunk #2 succeeded at 277.
Hunk #3 succeeded at 340.
Hunk #4 succeeded at 378.
Hunk #5 succeeded at 394.
Hunk #6 succeeded at 405.
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: sapi/fpm/config.m4
|===================================================================
|--- sapi/fpm/config.m4 (rйvision 303306)
|+++ sapi/fpm/config.m4 (copie de travail)
--------------------------
Patching file sapi/fpm/config.m4 using Plan A...
Hunk #1 failed at 2.
Hunk #2 failed at 311.
Hunk #3 succeeded at 333 (offset -23 lines).
2 out of 3 hunks failed--saving rejects to sapi/fpm/config.m4.rej
done
---
Does the script mov_conv.php call an external program ? (like 
/usr/local/bin/ffmpeg) - Yes


What else information has enough?
 [2010-10-20 15:42 UTC] fat@php.net
-Status: Open +Status: Feedback
 [2010-10-20 15:42 UTC] fat@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.


you need to apply the patch on the last snapshot (http://snaps.php.net/). Don't 
try to apply the patch on the 5.3.3 sources.

Apply the patch and submit results back here.
 [2010-10-20 16:16 UTC] 102956 at mail dot ru
-Status: Feedback +Status: Open
 [2010-10-20 16:16 UTC] 102956 at mail dot ru
I have successfully installed patch fpm-nomorelibevent.v8.patch on last snapshot (php5.3-201010201230) and have reinstalled php, php-fpm was successfully launched, sites work correctly. I will observe that will happen further within several days after that I can inform on results? To make it in mine bug report?

Thanks for the help, I hope that the problem will disappear.
 [2010-10-20 16:36 UTC] fat@php.net
-Status: Open +Status: Analyzed
 [2010-10-20 16:36 UTC] fat@php.net
yes, report back to me (in this bug report or by mail to fat at php dot net) when 
you think the problem won't appear again.

Thx
++ jerome
 [2010-11-11 18:13 UTC] fat@php.net
-Status: Analyzed +Status: Bogus
 [2010-11-11 18:13 UTC] fat@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

I close this bug report and continue in bug #52501

++ jerome
 [2010-11-15 10:36 UTC] 102956 at mail dot ru
Greetings. The problem has left, now php-fpm works like clock-work. Thanks.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC