php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52474 CURL fails to load
Submitted: 2010-07-28 19:52 UTC Modified: 2010-07-29 12:50 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: donraman@php.net Assigned: pajoye (profile)
Status: Duplicate Package: cURL related
PHP Version: 5.2.14 OS: Windows
Private report: No CVE-ID: None
 [2010-07-28 19:52 UTC] donraman@php.net
Description:
------------
I am using PHP5.2.14 NTS MSI on Windows 7. But I think Windows version doesn't matter.
When I enable the PHP extension cURL from the MSI, it's not getting shown as enabled in a simple phpinfo() page.

Running php-cgi.exe -v from command line gives me this error if extension cURL is enabled:

---------------------------
php-cgi.exe - System Error
---------------------------
The program can't start because zlib.dll is missing from your computer. Try reinstalling the program to fix this problem. 
---------------------------
OK   
---------------------------

I am not sure when this dependency was introduced or it was already present. I believe the MSI should have the dependent DLL too. Am I missing something?

Test script:
---------------
Part of php.ini:
[PHP_CURL]
extension=php_curl.dll

Sample Code:
<?php
// create a new cURL resource
$ch = curl_init();

// set URL and other appropriate options
curl_setopt($ch, CURLOPT_URL, "http://www.iis.net/");
curl_setopt($ch, CURLOPT_HEADER, 0);

// grab URL and pass it to the browser
curl_exec($ch);

// close cURL resource, and free up system resources
curl_close($ch);
?> 

Expected result:
----------------
proper execution of the script.

Actual result:
--------------
[28-Jul-2010 10:51:34] PHP Fatal error:  Call to undefined function curl_init() in C:\inetpub\wwwroot\phptest\test.php on line 3

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-07-29 09:08 UTC] pajoye@php.net
-Status: Open +Status: Bogus -Assigned To: +Assigned To: pajoye
 [2010-07-29 09:08 UTC] pajoye@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

#52452
 [2010-07-29 10:32 UTC] donraman@php.net
Mr. Pierre.

I have not submitted same bug again. And please don't sing the same song you sing to others. What is the duplicate bug number? Please close this bug as duplicate if there already exists a bug rather then letting me know not to file the bug again.

Well I am surprised that the bug exists and this is the reply from one of the person:



From: madavapeddi suman [mailto:suman.madavapeddi@gmail.com] 
Sent: Wednesday, July 28, 2010 1:28 PM
To: Venkat Raman Don
Subject: Re: [PHP-WIN] Problems installing cURL using PHP5.2.14

Hi Don , 

  This is suman, I used to work in OSTC Team in Microsoft .Now iam not there .This  Problem has occured while i was testing 
RC(5.2.14RC1,5.3.3RC1) and RC2's also.At That time Pierre Joye has given a different rebuild of the Binaries of PHP 5.2.14,5.3.3 RC's and asked us to test and it overcame that error.

Thanks,
Suman
On Wed, Jul 28, 2010 at 1:56 PM, Venkat Raman Don <Don.Raman@microsoft.com> wrote:
Hi,

I have filed bug at http://bugs.php.net/bug.php?id=52474. Has anyone else seen this?

If this is a genuine bug we need to repackage the MSI and re-release it. Thoughts?. Pierre.

Thanks,
Don.

Well the surprise is that even when someone reported it in pre release builds, the release builds still show the problem. I am stunned at it. Rather then letting me know that not to file duplicate bugs, Mr. Pierre what are you doing about it? If you can't fix it please shut your mouth and be quiet.

And your statement about thanking about your interest in PHP, let me tell you I have helped PHP community more than you. Look at IIS PHP forum and you will know and also the PHP User Windows List. 

And now give the duplicate bug id.

Don.
 [2010-07-29 10:39 UTC] pajoye@php.net
Maybe you should read the comment in the other report instead of copying non public mail here.

Also testing what I've asked in the other report would have told you that this problem has been resolved.

And no, there was no report before the release. The issues that Suman refers to was something different.
 [2010-07-29 11:03 UTC] donraman@php.net
What do you mean by resolved? There are people who have downloaded PHP5.2.14 bits (including me) and they have failed installing cURL. How the probblem has been resolved? Can you explain please?

And this is not a bogus bug. Please have some sense before resolving it as Bogus. I am able to reproduce it.
 [2010-07-29 11:09 UTC] pajoye@php.net
Are you able to reproduce it today? Using the binaries on http://windows.php.net?

In any case, this bug is a duplicate (> bogus) of the bug #52452 (as said already in my previous comment). Please use #52452 for any further discussions.
 [2010-07-29 11:25 UTC] donraman@php.net
Said by Mr. Joye:
"Are you able to reproduce it today? Using the binaries on http://windows.php.net?"

WOW I am surprised. I told you I am able to reproduce this with an official release of PHP5.2.14. I hope you Mr. Joye do not treat this as a daily build kind of thing? Because if I understand this is the final release of PHP 5.2 series.

Bogus. My foot. I have copied the initial PHP5.2.14 release and this is a genuine bug. So please be careful in your resolution. This is not a BOGUS bug. I tried it with initial PHP 5.2.14 release and can reproduce this. Do you Mr. Joye even know what BOGUS is?

And Mr. Joye (well known in community as Mr Pierre), if there is a defect which already exist close this defect as duplicate rather than bogus. The person who is filing bugs is not meant to look at all the bugs filed in PHP. BTW, may be Mr. Joye you can tell a way to do that.

If this bug gets closed as BOGUS, it is an insult to PHP community and all the people who are testing PHP. Because this is a genuine bug and I can't see why a genuine bug should be resolved as BOGUS? This hurts...
 [2010-07-29 11:55 UTC] donraman@php.net
I have few points more:

Do we even understand the impact when on php.net there is a news saying that this is the final release of 5.2 and we are silently changing things in between

Can we write to everyone (an announcement again) that this is fixed and the binaries has been modified so that people who have already downloaded can downlaod the new bits

Thats what i am driving at.

And please do not close this as BOGUS.
 [2010-07-29 12:00 UTC] donraman@php.net
-Status: Bogus +Status: Open
 [2010-07-29 12:17 UTC] pajoye@php.net
-Status: Assigned +Status: Duplicate
 [2010-07-29 12:17 UTC] pajoye@php.net
Again, duplicated.
 [2010-07-29 12:41 UTC] donraman@php.net
Thanks for duplication rather than bogus.

I stilll have the problem stated below:

Do we even understand the impact when on php.net there is a news saying that this is the final release of 5.2 and we are silently changing things in between

And in my opinion resolution is:

Can we write to everyone (an announcement again) that this is fixed and the binaries has been modified so that people who have already downloaded can downlaod the new bits

This wil help others.
 [2010-07-29 12:50 UTC] pajoye@php.net
-Block user comment: N +Block user comment: Y
 [2010-07-29 12:50 UTC] pajoye@php.net
I did mark as duplicate in the first place, as stated the comment. The status was not set to duplicate but to bogus (something remaining from the old bug tracker).

However this report is still not the place to comment, but the other report.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sun Sep 23 13:01:25 2018 UTC