php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52452 Curl cannt work
Submitted: 2010-07-27 08:34 UTC Modified: 2010-11-03 12:21 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: bluephp at gmail dot com Assigned: pajoye (profile)
Status: Closed Package: cURL related
PHP Version: 5.2.14 OS: windows 2003 server
Private report: No CVE-ID: None
 [2010-07-27 08:34 UTC] bluephp at gmail dot com
Description:
------------
The problem happened just after I updated php_5.2.13 to php_5.2.14. You known, the php_5.2.13 is working well. I rename D:\php to D:\php_5.2.13,and rename D:\php_5.2.14 to D:\php ,and copy D:\php_5.2.13\php.ini to D:\php .Then restart IIS.

When php_5.2.14 is running,
I run the Test script , it didnot work.
The D:\php\error.log said about "not loading the php_curl.dll".
But the D:\php\ext\php_curl.dll is existing and the D:\php\php.ini options of php_curl.dll is open.
Then I run D:\php\php.exe -m, it still didnot work. Alert window said about "the zlib.dll is error".
I found the size of php_curl.dll in php_5.2.14 is small than in php_5.2.13. But other files in D:\php\ext is same of size.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-07-27 12:05 UTC] pajoye@php.net
-Status: Open +Status: Feedback
 [2010-07-27 12:05 UTC] pajoye@php.net
Please try again using the binaries at http://windows.php.net/releases/
 [2010-07-27 16:57 UTC] jean-yves dot deleze at crealp dot vs dot ch
I experienced the same problem with the binaries released on the 22nd of july (build date : 2010-07-21). A workaround was to add the zlib library (version 1.2.3) into the system path or into the PHP directory (with filename zlib.dll, not zlib1.dll).

The binaries at http://windows.php.net/releases/ (build date : 2010-07-27) work like expected, without any zlib.dll related error.
 [2010-07-27 17:15 UTC] pajoye@php.net
-Status: Feedback +Status: Closed -Assigned To: +Assigned To: pajoye
 [2010-07-30 09:55 UTC] jean-yves dot deleze at crealp dot vs dot ch
Just a comment to note that the binaries on the main PHP download page (http://php.net/downloads.php) still contain the bug (build date : 2007-07-21). 

Please update these files or add a link to http://windows.php.net/download/ (like you did for the PHP 5.3.x branch).
 [2010-10-19 13:22 UTC] pankaj dot jangid at gmail dot com
The binaries on the main PHP download page (http://php.net/downloads.php) still contain the bug (build date : 2007-07-21).

People are downloading a buggy releases and cribbing about PHP. Please fix that. That's just an HTML edit.
 [2010-10-19 13:48 UTC] pankaj dot jangid at gmail dot com
The CURL in my installation is still not working. I tool 2010-07-27 5.2.14 release. I have tried putting zlib 1.2.5 as well as zlib 1.2.3 in to C:\WINDOWS\System32 directory.
 [2010-10-24 20:47 UTC] spencer19_82 at hotmail dot com
Hi,

I don't understand why the status of this bug is Closed. The problem still exists 
in 5.2.14. 

Has a patch been released, if so where? If not, what is the workaround? 

Thanks,

RS
 [2010-10-24 21:46 UTC] pajoye@php.net
Fetch the releases from  http://windows.php.net/download/ ....
 [2010-11-01 05:00 UTC] time_4_a_break at yahoo dot com
Search your computer for a valid zlib.dll file.  I used the version that came with Macromedia Dreamweaver 8.  No error.
 [2010-11-03 12:04 UTC] peter dot bailey97 at ntlworld dot com
I'm having the same problem with both the windows installer and the zipped up binaries.

Apache error log reports:
PHP Warning:  PHP Startup: Unable to load dynamic library '{obscured}php_curl.dll' - The specified module could not be found.\r\n in Unknown on line 0

I replaced the 5.2.14 php_curl.dll (stamped 21/07/10 18:44) with the old backup I had from 5.2.6 and the problem appears to go away. I'm not that comfortable with swapping in such an old DLL though.
 [2010-11-03 12:21 UTC] pajoye@php.net
-Block user comment: N +Block user comment: Y
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon May 27 07:01:26 2019 UTC