php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #492 Secure Server & PHP3
Submitted: 1998-06-29 14:14 UTC Modified: 1998-06-29 14:17 UTC
From: nat at DeZines dot com Assigned:
Status: Closed Package: Other
PHP Version: 3.0 Final Release OS: Sun 2.x, Apache 1.2.6, Apache-SS
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
45 + 4 = ?
Subscribe to this entry?

 
 [1998-06-29 14:14 UTC] nat at DeZines dot com
This may not be a bug, but I could not find this documented anywhere on your web site.

Can PHP3 work in SSL mode?

We use Apache-SSL, and we have this configured in the srm.conf file:
AddType application/x-httpd-php3 .php3

However, when we try to access a test page using https://

we get a window in our web browser:

"You have started to download a file of type application/x-httpd-php3"

SAVE AS ....



What else is needed to get PHP3 to work in SSL mode?


Thank you
Nathalie

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-06-29 14:17 UTC] rasmus
No bug.  PHP works fine with Apache-SSL.  You have to make sure you compile your httpsd binary with PHP linked in, of course.
 [2011-05-16 17:21 UTC] dtajchreber@php.net
Automatic comment from SVN on behalf of dtajchreber
Revision: http://svn.php.net/viewvc/?view=revision&revision=311085
Log: Doc Bug #54749 - Missing default value for last parameter of mysqli_query - added MYSQLI_STORE_RESULT as default value for resultmode in signatures

http://lxr.php.net/opengrok/xref/PHP_5_3/ext/mysqli/mysqli_nonapi.c#492
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Dec 03 00:05:54 2022 UTC