|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #54749 Missing default value for last parameter of mysqli_query
Submitted: 2011-05-16 17:10 UTC Modified: 2011-05-16 17:23 UTC
From: gwarnants at gmail dot com Assigned: dtajchreber (profile)
Status: Closed Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2011-05-16 17:10 UTC] gwarnants at gmail dot com
From manual page:

Details tells "By default, MYSQLI_STORE_RESULT is used." but that default value is missing in procedural and oop prototypes. I think they should be :

mixed mysqli::query ( string $query [, int $resultmode = MYSQLI_STORE_RESULT ] )
mixed mysqli_query ( mysqli $link , string $query [, int $resultmode = MYSQLI_STORE_RESULT ] )


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2011-05-16 17:21 UTC]
Automatic comment from SVN on behalf of dtajchreber
Log: Doc Bug #54749 - Missing default value for last parameter of mysqli_query - added MYSQLI_STORE_RESULT as default value for resultmode in signatures
 [2011-05-16 17:23 UTC]
-Status: Open +Status: Closed -Assigned To: +Assigned To: dtajchreber
 [2011-05-16 17:23 UTC]
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.

Thanks. I see you're opening a lot of these; if possible, please try using the web 
interface ( to correct them by yourself.
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC