php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47134 Install issue with PHP 5.2.8 installer
Submitted: 2009-01-17 02:59 UTC Modified: 2009-02-13 11:05 UTC
Votes:17
Avg. Score:4.8 ± 0.6
Reproduced:14 of 15 (93.3%)
Same Version:14 (100.0%)
Same OS:12 (85.7%)
From: craig dot emenaker at gmail dot com Assigned: jmertic (profile)
Status: Closed Package: Windows Installer
PHP Version: 5.2.8 OS: Windows XP Pro
Private report: No CVE-ID: None
 [2009-01-17 02:59 UTC] craig dot emenaker at gmail dot com
Description:
------------
Downloaded PHP 5.2.8 installer (Windows Binaries).  When trying to install, I get a message, "There is a problem with this Windows Installer package.  A script required for this install to complete could not be run.  Contact your support personnel or package vendor."

I tried both "IIS ISAPI module" and "IIS CGI" set-up types, and got the same error regardless.

Reproduce code:
---------------
n/a - Download/install issue.

Expected result:
----------------
Clean install

Actual result:
--------------
Error msg:

"There is a problem with this Windows Installer package.  A script required for this install to complete could not be run.  Contact your support personnel or package vendor."

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-01-17 11:00 UTC] bjori@php.net
reclassified
 [2009-01-17 19:52 UTC] boicenet at gmail dot com
I just tried installing 5.2.8 and am receiving the same Installer message regarding a missing script. Is there a resolution to this issue? Seems it has been around at least for a few versions of PHP 5.2.x.

Thanks.
 [2009-01-17 20:30 UTC] jmertic@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 [2009-01-18 03:02 UTC] craig dot emenaker at gmail dot com
I went to the http://snaps.php.net/ page.

Based on the descriptions as to which version to download ("If you are using PHP with IIS you should use the VC9 versions of PHP"), I selected Windows x86 VC9 (thread safe)).  I'm not sure about the "thread safe" vs. "non thread safe", though.  I selected the "thread safe" Installer, but got the following error when trying to install:

"The installer has encountered an unexpected error installing this package.  This may indicate a problem with this package.  The error code is 2356."
 [2009-02-01 19:50 UTC] david dot barrass at ed dot ac dot uk
Got it working by changing permissions on the apache directory so I could add things to the directory
 [2009-02-06 18:33 UTC] edwin at cs dot uct dot ac dot za
Workaround for Bug #46581 namely unpack the zip version to the PHP installation directory then running installer, seems to work
 [2009-02-06 18:52 UTC] pajoye@php.net
Please try using the 5.2.9RC1 installer or the snapshots.
 [2009-02-13 10:58 UTC] denise dot norris at theservicedesk dot biz
Release candidate 5.2.9RC2 VC6 worked successfully for me after experiencing the error with 5.2.8 V6 using IIS ISAPI Module.
 [2009-02-13 11:05 UTC] pajoye@php.net
fixed
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sat Nov 17 02:01:25 2018 UTC