php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42771 php compilation wrongly assumes mysql directory structure
Submitted: 2007-09-26 23:31 UTC Modified: 2007-09-27 07:41 UTC
From: wangoo dot tangoo at yahoo dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.2.4 OS: os x
Private report: No CVE-ID: None
 [2007-09-26 23:31 UTC] wangoo dot tangoo at yahoo dot com
Description:
------------
--with-mysql config option assumes that the mysql library hierarchy is 
always the same on any machine.

Reproduce code:
---------------
Install mysql from source on OS X.
Libraries will be placed in /usr/local/mysql/lib

Run: ./configure --with-mysql /usr/local/mysql

Expected result:
----------------
I expect to point the config to the library and have it use the library
I point to.

I expect a compilable configuration

Actual result:
--------------
Configuration fails because it assumes that the libraries are
in: /usr/local/mysql/lib/mysql

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-09-27 07:41 UTC] scottmac@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

See bug #42515
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Aug 11 05:05:45 2022 UTC