php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #42515 MySQL Library Locations Incorrect
Submitted: 2007-09-01 19:54 UTC Modified: 2007-09-03 07:53 UTC
Votes:3
Avg. Score:4.3 ± 0.9
Reproduced:3 of 3 (100.0%)
Same Version:2 (66.7%)
Same OS:3 (100.0%)
From: geoffers at gmail dot com Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 5.2.4 OS: Mac OS 10.4.10
Private report: No CVE-ID: None
 [2007-09-01 19:54 UTC] geoffers at gmail dot com
Description:
------------
As #42464 is marked as bogus, and I cannot therefore comment on that:

The official MySQL binaries install at /usr/local/mysql. PHP tries to 
read from /usr/local/mysql/lib/mysql, which does not exist.

The prior bug was marked as bogus due to ./buildconf being used: on a 
non-"hackish" copy of PHP it fails too. Running just:
% cd php-5.2.4
% ./configure --with-mysql=/usr/local/mysql

./configure doesn't fail like jani claimed. Instead, it says that a 
system library hasn't been found, and to email php-install. If you try 
to run make regardless, it succeeds, but you cannot do anything with 
the 
binary as it cannot load the libraries.

Take a clean OS X install, install the mysql,org binary, then try to 
compile PHP as above. It'll fail. This isn't a bogus report. This is a 
real bug, which really makes PHP totally unusable.




Reproduce code:
---------------
% cd php-5.2.4
% ./configure --with-mysql=/usr/local/mysql
% make

Expected result:
----------------
Working PHP binary to be produced

Actual result:
--------------
A non-working PHP binary, trying to load dynamic libraries (which exist 
in /usr/local/mysql/lib) from /usr/local/mysql/lib/mysql).

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-09-02 15:32 UTC] jerry at scene-naturally dot dyndns dot org
Try installing the source version either the 5.1 development version or 
the 5.0.nn version. doing so adds in the correct libs, etc.

The 5.1 source is at the bottom of

http://dev.mysql.com/downloads/mysql/5.1.html


(note: usually binary packages are not suited for using to build other 
softwares.)
 [2007-09-02 18:33 UTC] buildsmart at daleenterprise dot com
I can comment on this bug and this bug is bogus, the error is caused by 
faulty binaries provided by mysql.org/mysql.com and not by PHP.

c12.apple.com:~ root# otool -L /usr/local/mysql/lib/libmysqlclient.
15.dylib
/usr/local/mysql/lib/libmysqlclient.15.dylib:
        /usr/local/mysql/lib/mysql/libmysqlclient.15.dylib 
(compatibility version 16.0.0, current version 16.0.0)
        /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current 
version 88.1.5)
 [2007-09-03 07:53 UTC] jani@php.net
Mysql bug is not PHP bug. :)
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Oct 05 08:05:55 2022 UTC