php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41055 DOTNET not instantiating fully-pathed assembly
Submitted: 2007-04-11 18:06 UTC Modified: 2020-07-05 04:22 UTC
Votes:28
Avg. Score:3.1 ± 0.4
Reproduced:3 of 4 (75.0%)
Same Version:1 (33.3%)
Same OS:0 (0.0%)
From: daarond at gmail dot com Assigned: cmb (profile)
Status: No Feedback Package: COM related
PHP Version: 5CVS-2007-04-11 (snap) OS: WinXP
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2007-04-11 18:06 UTC] daarond at gmail dot com
Description:
------------
Bug #29800 did not pursue it, but I would like to go forward with resolving it.

I have a strongly-typed assembly that I added to the GAC. By the way, the simplest way to get the token information is to use gacutil with the /l switch.

To fully reproduce it, you can download the DLLs I am using:
http://www.angorasoftware.com/test/Core.zip


Reproduce code:
---------------
<?php
$dotobj = new DOTNET("watin.core, Version=1.1.0.1001, Culture=neutral, PublicKeyToken=b26a14bb9ccc0290, processorArchitecture=MSIL", "WatiN.Core.IE"); 
$dotobj = null;
?>

Expected result:
----------------
It should open a web page.

Actual result:
--------------
PHP Fatal error:  Uncaught exception 'com_exception' with message 'Failed to instantiate .Net object [CreateInstance] [0x80131604] ' in C:\PHP5\wtest.php:3
Stack trace:
#0 C:\PHP5\wtest.php(3): dotnet->dotnet('watin.core, Ver...', 'WatiN.Core.IE')
#1 {main}
  thrown in C:\PHP5\wtest.php on line 3

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-08-15 08:34 UTC] jani@php.net
Assigned to the maintainer.
 [2013-12-13 07:48 UTC] wez@php.net
-Status: Assigned +Status: Open -Assigned To: wez +Assigned To:
 [2020-06-25 15:55 UTC] cmb@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2020-06-25 15:55 UTC] cmb@php.net
It's hard to tell why the class can't be instantiated without
having access to the class (or its documentation).  If this issue
is still relevant, please provide the DLL again.  Thanks.
 [2020-07-05 04:22 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Oct 28 15:01:23 2020 UTC