php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39795 make fails with rc01
Submitted: 2006-12-11 08:52 UTC Modified: 2006-12-15 09:10 UTC
From: michael dot kurz at lrp dot de Assigned:
Status: Closed Package: Compile Failure
PHP Version: 5CVS-2006-12-11 (snap) OS: AIX 5.2, ML08-01
Private report: No CVE-ID:
 [2006-12-11 08:52 UTC] michael dot kurz at lrp dot de
Description:
------------
snap = php5.2-200612110530
aix level see above
Compiler = C for Aix 6.0

configure without any failures
make crashes after a while with rc=1

base version any many snaps tested with same or similar results

Reproduce code:
---------------
./configure --with-oci8=/dba/app/oracle/102 --with-oracle=/dba/app/oracle/102 --enable-sigchild

make 

.
.
.


Expected result:
----------------
Should compile properly.

Actual result:
--------------
        /bin/sh /tempdata/xxx/php5.2-200612110530/libtool --silent --preserve-dup-deps --mode=compile cc  -Iext/standard/ -I/tempdata/xxx/php5.2-200612110530/ext/standa
rd/ -DPHP_ATOM_INC -I/tempdata/xxx/php5.2-200612110530/include -I/tempdata/xxx/php5.2-200612110530/main -I/tempdata/xxx/php5.2-200612110530 -I/opt/freeware/include/libx
ml2 -I/tempdata/xxx/php5.2-200612110530/ext/date/lib -I/dba/app/oracle/102/rdbms/public -I/dba/app/oracle/102/rdbms/demo -I/dba/app/oracle/102/plsql/public -I/tempdata/
xxx/php5.2-200612110530/TSRM -I/tempdata/xxx/php5.2-200612110530/Zend    -I/usr/include -g  -c /tempdata/xxx/php5.2-200612110530/ext/standard/crc32.c -o ext/standard/cr
c32.lo 
        /bin/sh /tempdata/xxx/php5.2-200612110530/libtool --silent --preserve-dup-deps --mode=compile cc  -Iext/standard/ -I/tempdata/xxx/php5.2-200612110530/ext/standa
rd/ -DPHP_ATOM_INC -I/tempdata/xxx/php5.2-200612110530/include -I/tempdata/xxx/php5.2-200612110530/main -I/tempdata/xxx/php5.2-200612110530 -I/opt/freeware/include/libx
ml2 -I/tempdata/xxx/php5.2-200612110530/ext/date/lib -I/dba/app/oracle/102/rdbms/public -I/dba/app/oracle/102/rdbms/demo -I/dba/app/oracle/102/plsql/public -I/tempdata/
xxx/php5.2-200612110530/TSRM -I/tempdata/xxx/php5.2-200612110530/Zend    -I/usr/include -g  -c /tempdata/xxx/php5.2-200612110530/ext/standard/crypt.c -o ext/standard/cr
ypt.lo 
"/tempdata/xxx/php5.2-200612110530/ext/standard/crypt.c", line 150.24: 1506-007 (S) "struct crypt_data" is undefined.
"/tempdata/xxx/php5.2-200612110530/ext/standard/crypt.c", line 152.17: 1506-196 (W) Initialization between types "unsigned char*" and "int" is not allowed.
make: The error code from the last command is 1.


Stop.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-12-11 12:28 UTC] tony2001@php.net
Please try this patch:
http://tony2001.phpclub.net/dev/tmp/crypt_r.diff
apply it with patch -p0 < crypt_r.diff, then run 
./buildconf && ./config.nice && make
 [2006-12-11 13:02 UTC] michael dot kurz at lrp dot de
Hi,

Im not able to apply the patch
Look here:

root@lrp-vks01:/repository/php-src# patch -p0 < crypt_r.diff
Hmm...  I can't seem to find a patch in there anywhere.
root@lrp-vks01:/repository/php-src#

What is the mistake?
crypt_r.diff is located the the php-src directory
-rwxr-xr-x   1 root     system         3545 Dec 11 13:35 crypt_r.diff
 [2006-12-11 13:13 UTC] tony2001@php.net
Argh.. Is it possible to install GNU patchutils?
AIX seems to have some kind of broken "patch", which does not understand unified diffs.
 [2006-12-11 13:55 UTC] michael dot kurz at lrp dot de
I tried to install patchutils 0.2.31 , but make crashed in filterdiff.c.

Sorry.
 [2006-12-11 14:11 UTC] tony2001@php.net
Ok, I uploaded the diff, which your "patch" should be able to read.
 [2006-12-11 14:15 UTC] michael dot kurz at lrp dot de
Ok, but where can I download it?
 [2006-12-11 14:31 UTC] tony2001@php.net
URL is the very same.
 [2006-12-12 07:04 UTC] michael dot kurz at lrp dot de
patch now is done, but buildconf crashes

root@lrp-vks01:/tempdata/xxx/php5.2-200612110530# ./buildconf
using default Zend directory
buildconf: checking installation...
buildconf: autoconf version 2.59 (ok)
buildconf: Your version of autoconf likely contains buggy cache code.
           Running cvsclean for you.
           To avoid this, install autoconf-2.13.
"build/build2.mk", line 32: make: Dependency line needs colon or double colon operator.
"build/build2.mk", line 33: make: Dependency line needs colon or double colon operator.
"build/build2.mk", line 35: make: Dependency line needs colon or double colon operator.
make: Fatal errors encountered -- cannot continue.
make: The error code from the last command is 2.


Stop.

autoconf Version 2.13 could not be installed, cause make runs in error

root@lrp-vks01:/tempdata/autoconf-2.13# make
Error: Autoconf requires GNU m4 1.1 or later
make: The error code from the last command is 1.


Stop.

...and m4 is installed
root@lrp-vks01:/tempdata/autoconf-2.13# lslpp -L |grep m4
  m4                         1.4.1-1    C     R    The GNU macro processor.
root@lrp-vks01:/tempdata/autoconf-2.13#


Just for fun I tested ./configure --with=/dba ... && make, but 

/bin/sh /tempdata/xxx/php5.2-200612110530/libtool --silent --preserve-dup-deps --mode=compile cc  -Iext/standard/ -I/tempdata/xxx/php5
.2-200612110530/ext/standard/ -DPHP_ATOM_INC -I/tempdata/xxx/php5.2-200612110530/include -I/tempdata/xxx/php5.2-200612110530/main -I/tempdata/
xxx/php5.2-200612110530 -I/opt/freeware/include/libxml2 -I/tempdata/xxx/php5.2-200612110530/ext/date/lib -I/dba/app/oracle/102/rdbms/public -I
/dba/app/oracle/102/rdbms/demo -I/dba/app/oracle/102/plsql/public -I/tempdata/xxx/php5.2-200612110530/TSRM -I/tempdata/xxx/php5.2-200612110530
/Zend    -I/usr/include -g  -c /tempdata/xxx/php5.2-200612110530/ext/standard/crypt.c -o ext/standard/crypt.lo 
"/tempdata/xxx/php5.2-200612110530/ext/standard/crypt.c", line 159.2: 1506-205 (S) #error Data struct used by crypt_r() is unknown. Please rep
ort.
"/tempdata/xxx/php5.2-200612110530/ext/standard/crypt.c", line 161.1: 1506-275 (S) Unexpected text ':' encountered.
"/tempdata/xxx/php5.2-200612110530/ext/standard/crypt.c", line 162.17: 1506-277 (S) Syntax error: possible missing ';' or ','?
"/tempdata/xxx/php5.2-200612110530/ext/standard/crypt.c", line 162.51: 1506-045 (S) Undeclared identifier buffer.
"/tempdata/xxx/php5.2-200612110530/ext/standard/crypt.c", line 162.17: 1506-196 (W) Initialization between types "unsigned char*" and "int" is
 not allowed.
make: The error code from the last command is 1.


Stop.
root@lrp-vks01:/tempdata/xxx/php5.2-200612110530#
 [2006-12-12 07:40 UTC] tony2001@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.2-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.2-win32-latest.zip

Ok, I got it. I'll commit it first, and then you'll grab a snapshot and test it, or we may end up installing Linux trying to fix AIX..
It works fine here on AIX with and without the patch, so I just want to make sure it fixes the problem for you.
Please try the _next_ snapshot (it'll be ready in ~2 hours).
 [2006-12-12 10:00 UTC] michael dot kurz at lrp dot de
with and without the patch the result looks like that:

(./configure --with-...)

checking whether utime accepts a null argument... yes
checking for working alloca.h... (cached) yes
checking for alloca... yes
checking for declared timezone... yes
checking for type of reentrant time-related functions... POSIX
checking for readdir_r... yes
checking for type of readdir_r... POSIX
checking for in_addr_t... yes
checking for crypt_r... yes
checking which data struct is used by crypt_r... none
configure: error: Unable to detect data struct is used by crypt_r
root@lrp-vks01:/tempdata/php5.2-200612120930#
 [2006-12-12 10:14 UTC] tony2001@php.net
Please provide an account on this machine.
 [2006-12-12 10:25 UTC] michael dot kurz at lrp dot de
this is not possible!
 [2006-12-12 10:33 UTC] tony2001@php.net
I can't reproduce it on AIX 5.1, which basically means I can't help you. 
Try to find out what is the data struct used by crypt_r() and why it cannot be detected by PHP_CRYPT_R_STYLE() macro in acinclude.m4.
 [2006-12-12 10:56 UTC] michael dot kurz at lrp dot de
ok, this means I cannot use php. I'm a sysadmin and not programmer and have not the knowhow (and the time) to do this.

But isn't aix5.1 out of service?
Are you not able to migrate your machine?
 [2006-12-12 11:01 UTC] tony2001@php.net
>ok, this means I cannot use php. I'm a sysadmin and not 
>programmer and have not the knowhow (and the time) to do this.
You can provide me an account on this machine and I'll try to help you. I can't fix it as long as I can't reproduce it.

>But isn't aix5.1 out of service?
>Are you not able to migrate your machine?
Why should I? I don't have any problems.
Why don't you migrate on some working OS?
 [2006-12-12 11:15 UTC] michael dot kurz at lrp dot de
I can provide an account, but you will not be able to connect to the machine, cause our firewall doesn't permit it. 

>>Are you not able to migrate your machine?
>Why should I? I don't have any problems.
>Why don't you migrate on some working OS?

You will not get any support by ibm for any problem with the  os. Is this not reason enough?

If you are using a big database in a cluster, you need the actual os on actual hardware. This is not running on dos!
 [2006-12-12 12:06 UTC] tony2001@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 [2006-12-13 06:27 UTC] michael dot kurz at lrp dot de
...but I think we are on the target line


        /bin/sh /tempdata/php5.2-200612121330/libtool --silent --preserve-dup-deps --mode=compile cc  -IZend/ -I/tempdata/php5.2-200612121330/Zend/ -DPHP_ATOM_INC -I/tempdata/php5.2-200612121330/include -I/tempdata/php5.2-200612121330/main -I/tempdata/php5.2-200612121330 -I/opt/freeware/include/libxml2 -I/tempdata/php5.2-200612121330/ext/date/lib -I/dba/app/oracle/102/rdbms/public -I/dba/app/oracle/102/rdbms/demo -I/dba/app/oracle/102/plsql/public -I/tempdata/php5.2-200612121330/TSRM -I/tempdata/php5.2-200612121330/Zend    -I/usr/include -g  -c /tempdata/php5.2-200612121330/Zend/zend_alloc.c -o Zend/zend_alloc.lo
"/tempdata/php5.2-200612121330/Zend/zend_alloc.c", line 274.28: 1506-243 (S) Value of enumeration constant must be in range of signed integer.
"/tempdata/php5.2-200612121330/Zend/zend_alloc.c", line 275.28: 1506-243 (S) Value of enumeration constant must be in range of signed integer.
make: The error code from the last command is 1.


Stop.
 [2006-12-13 06:32 UTC] michael dot kurz at lrp dot de
.
 [2006-12-13 09:38 UTC] tony2001@php.net
Please provide full error message instead of the (useless) last line.
 [2006-12-13 09:59 UTC] michael dot kurz at lrp dot de
/bin/sh /tempdata/php5.2-200612121330/libtool --silent --preserve-dup-deps --mode=compile cc  -Imain/streams/ -I/tempdata/php5.2-200612121330/main/streams/ -DPHP_ATOM_INC -I/tempdata/php5.2-200612121330/include -I/tempdata/php5.2-200612121330/main -I/tempdata/php5.2-200612121330 -I/opt/freeware/include/libxml2 -I/tempdata/php5.2-200612121330/ext/date/lib -I/dba/app/oracle/102/rdbms/public -I/dba/app/oracle/102/rdbms/demo -I/dba/app/oracle/102/plsql/public -I/tempdata/php5.2-200612121330/TSRM -I/tempdata/php5.2-200612121330/Zend    -I/usr/include -g  -c /tempdata/php5.2-200612121330/main/streams/plain_wrapper.c -o main/streams/plain_wrapper.lo
        /bin/sh /tempdata/php5.2-200612121330/libtool --silent --preserve-dup-deps --mode=compile cc  -Imain/streams/ -I/tempdata/php5.2-200612121330/main/streams/ -DPHP_ATOM_INC -I/tempdata/php5.2-200612121330/include -I/tempdata/php5.2-200612121330/main -I/tempdata/php5.2-200612121330 -I/opt/freeware/include/libxml2 -I/tempdata/php5.2-200612121330/ext/date/lib -I/dba/app/oracle/102/rdbms/public -I/dba/app/oracle/102/rdbms/demo -I/dba/app/oracle/102/plsql/public -I/tempdata/php5.2-200612121330/TSRM -I/tempdata/php5.2-200612121330/Zend    -I/usr/include -g  -c /tempdata/php5.2-200612121330/main/streams/userspace.c -o main/streams/userspace.lo
        /bin/sh /tempdata/php5.2-200612121330/libtool --silent --preserve-dup-deps --mode=compile cc  -Imain/streams/ -I/tempdata/php5.2-200612121330/main/streams/ -DPHP_ATOM_INC -I/tempdata/php5.2-200612121330/include -I/tempdata/php5.2-200612121330/main -I/tempdata/php5.2-200612121330 -I/opt/freeware/include/libxml2 -I/tempdata/php5.2-200612121330/ext/date/lib -I/dba/app/oracle/102/rdbms/public -I/dba/app/oracle/102/rdbms/demo -I/dba/app/oracle/102/plsql/public -I/tempdata/php5.2-200612121330/TSRM -I/tempdata/php5.2-200612121330/Zend    -I/usr/include -g  -c /tempdata/php5.2-200612121330/main/streams/transports.c -o main/streams/transports.lo
        /bin/sh /tempdata/php5.2-200612121330/libtool --silent --preserve-dup-deps --mode=compile cc  -Imain/streams/ -I/tempdata/php5.2-200612121330/main/streams/ -DPHP_ATOM_INC -I/tempdata/php5.2-200612121330/include -I/tempdata/php5.2-200612121330/main -I/tempdata/php5.2-200612121330 -I/opt/freeware/include/libxml2 -I/tempdata/php5.2-200612121330/ext/date/lib -I/dba/app/oracle/102/rdbms/public -I/dba/app/oracle/102/rdbms/demo -I/dba/app/oracle/102/plsql/public -I/tempdata/php5.2-200612121330/TSRM -I/tempdata/php5.2-200612121330/Zend    -I/usr/include -g  -c /tempdata/php5.2-200612121330/main/streams/xp_socket.c -o main/streams/xp_socket.lo
        /bin/sh /tempdata/php5.2-200612121330/libtool --silent --preserve-dup-deps --mode=compile cc  -Imain/streams/ -I/tempdata/php5.2-200612121330/main/streams/ -DPHP_ATOM_INC -I/tempdata/php5.2-200612121330/include -I/tempdata/php5.2-200612121330/main -I/tempdata/php5.2-200612121330 -I/opt/freeware/include/libxml2 -I/tempdata/php5.2-200612121330/ext/date/lib -I/dba/app/oracle/102/rdbms/public -I/dba/app/oracle/102/rdbms/demo -I/dba/app/oracle/102/plsql/public -I/tempdata/php5.2-200612121330/TSRM -I/tempdata/php5.2-200612121330/Zend    -I/usr/include -g  -c /tempdata/php5.2-200612121330/main/streams/mmap.c -o main/streams/mmap.lo
        /bin/sh /tempdata/php5.2-200612121330/libtool --silent --preserve-dup-deps --mode=compile cc  -IZend/ -I/tempdata/php5.2-200612121330/Zend/ -DPHP_ATOM_INC -I/tempdata/php5.2-200612121330/include -I/tempdata/php5.2-200612121330/main -I/tempdata/php5.2-200612121330 -I/opt/freeware/include/libxml2 -I/tempdata/php5.2-200612121330/ext/date/lib -I/dba/app/oracle/102/rdbms/public -I/dba/app/oracle/102/rdbms/demo -I/dba/app/oracle/102/plsql/public -I/tempdata/php5.2-200612121330/TSRM -I/tempdata/php5.2-200612121330/Zend    -I/usr/include -g  -c Zend/zend_language_parser.c -o Zend/zend_language_parser.lo
        /bin/sh /tempdata/php5.2-200612121330/libtool --silent --preserve-dup-deps --mode=compile cc  -IZend/ -I/tempdata/php5.2-200612121330/Zend/ -DPHP_ATOM_INC -I/tempdata/php5.2-200612121330/include -I/tempdata/php5.2-200612121330/main -I/tempdata/php5.2-200612121330 -I/opt/freeware/include/libxml2 -I/tempdata/php5.2-200612121330/ext/date/lib -I/dba/app/oracle/102/rdbms/public -I/dba/app/oracle/102/rdbms/demo -I/dba/app/oracle/102/plsql/public -I/tempdata/php5.2-200612121330/TSRM -I/tempdata/php5.2-200612121330/Zend    -I/usr/include -g  -c Zend/zend_language_scanner.c -o Zend/zend_language_scanner.lo
        /bin/sh /tempdata/php5.2-200612121330/libtool --silent --preserve-dup-deps --mode=compile cc  -IZend/ -I/tempdata/php5.2-200612121330/Zend/ -DPHP_ATOM_INC -I/tempdata/php5.2-200612121330/include -I/tempdata/php5.2-200612121330/main -I/tempdata/php5.2-200612121330 -I/opt/freeware/include/libxml2 -I/tempdata/php5.2-200612121330/ext/date/lib -I/dba/app/oracle/102/rdbms/public -I/dba/app/oracle/102/rdbms/demo -I/dba/app/oracle/102/plsql/public -I/tempdata/php5.2-200612121330/TSRM -I/tempdata/php5.2-200612121330/Zend    -I/usr/include -g  -c Zend/zend_ini_parser.c -o Zend/zend_ini_parser.lo
        /bin/sh /tempdata/php5.2-200612121330/libtool --silent --preserve-dup-deps --mode=compile cc  -IZend/ -I/tempdata/php5.2-200612121330/Zend/ -DPHP_ATOM_INC -I/tempdata/php5.2-200612121330/include -I/tempdata/php5.2-200612121330/main -I/tempdata/php5.2-200612121330 -I/opt/freeware/include/libxml2 -I/tempdata/php5.2-200612121330/ext/date/lib -I/dba/app/oracle/102/rdbms/public -I/dba/app/oracle/102/rdbms/demo -I/dba/app/oracle/102/plsql/public -I/tempdata/php5.2-200612121330/TSRM -I/tempdata/php5.2-200612121330/Zend    -I/usr/include -g  -c Zend/zend_ini_scanner.c -o Zend/zend_ini_scanner.lo
        /bin/sh /tempdata/php5.2-200612121330/libtool --silent --preserve-dup-deps --mode=compile cc  -IZend/ -I/tempdata/php5.2-200612121330/Zend/ -DPHP_ATOM_INC -I/tempdata/php5.2-200612121330/include -I/tempdata/php5.2-200612121330/main -I/tempdata/php5.2-200612121330 -I/opt/freeware/include/libxml2 -I/tempdata/php5.2-200612121330/ext/date/lib -I/dba/app/oracle/102/rdbms/public -I/dba/app/oracle/102/rdbms/demo -I/dba/app/oracle/102/plsql/public -I/tempdata/php5.2-200612121330/TSRM -I/tempdata/php5.2-200612121330/Zend    -I/usr/include -g  -c /tempdata/php5.2-200612121330/Zend/zend_alloc.c -o Zend/zend_alloc.lo
"/tempdata/php5.2-200612121330/Zend/zend_alloc.c", line 274.28: 1506-243 (S) Value of enumeration constant must be in range of signed integer.
"/tempdata/php5.2-200612121330/Zend/zend_alloc.c", line 275.28: 1506-243 (S) Value of enumeration constant must be in range of signed integer.
make: The error code from the last command is 1.


Stop.
root@lrp-vks01:/tempdata/php5.2-200612121330#
 [2006-12-13 10:11 UTC] tony2001@php.net
I'm unable to see any problems using GCC.
 [2006-12-13 10:52 UTC] michael dot kurz at lrp dot de
uesd gcc 4.0.0 instead aix cc6.0

here's the result:

        /bin/sh /tempdata/php5.2-200612121330/libtool --silent --preserve-dup-deps --mode=compile cc  -IZend/ -I/tempdata/php5.2-200612121330/Zend/ -DPHP_ATOM_INC -I/tempdata/php5.2-200612121330/include -I/tempdata/php5.2-200612121330/main -I/tempdata/php5.2-200612121330 -I/opt/freeware/include/libxml2 -I/tempdata/php5.2-200612121330/ext/date/lib -I/dba/app/oracle/102/rdbms/public -I/dba/app/oracle/102/rdbms/demo -I/dba/app/oracle/102/plsql/public -I/tempdata/php5.2-200612121330/TSRM -I/tempdata/php5.2-200612121330/Zend    -I/usr/include -g  -c /tempdata/php5.2-200612121330/Zend/zend_object_handlers.c -o Zend/zend_object_handlers.lo
        /bin/sh /tempdata/php5.2-200612121330/libtool --silent --preserve-dup-deps --mode=compile cc  -IZend/ -I/tempdata/php5.2-200612121330/Zend/ -DPHP_ATOM_INC -I/tempdata/php5.2-200612121330/include -I/tempdata/php5.2-200612121330/main -I/tempdata/php5.2-200612121330 -I/opt/freeware/include/libxml2 -I/tempdata/php5.2-200612121330/ext/date/lib -I/dba/app/oracle/102/rdbms/public -I/dba/app/oracle/102/rdbms/demo -I/dba/app/oracle/102/plsql/public -I/tempdata/php5.2-200612121330/TSRM -I/tempdata/php5.2-200612121330/Zend    -I/usr/include -g  -c /tempdata/php5.2-200612121330/Zend/zend_objects_API.c -o Zend/zend_objects_API.lo
        /bin/sh /tempdata/php5.2-200612121330/libtool --silent --preserve-dup-deps --mode=compile cc  -IZend/ -I/tempdata/php5.2-200612121330/Zend/ -DPHP_ATOM_INC -I/tempdata/php5.2-200612121330/include -I/tempdata/php5.2-200612121330/main -I/tempdata/php5.2-200612121330 -I/opt/freeware/include/libxml2 -I/tempdata/php5.2-200612121330/ext/date/lib -I/dba/app/oracle/102/rdbms/public -I/dba/app/oracle/102/rdbms/demo -I/dba/app/oracle/102/plsql/public -I/tempdata/php5.2-200612121330/TSRM -I/tempdata/php5.2-200612121330/Zend    -I/usr/include -g  -c /tempdata/php5.2-200612121330/Zend/zend_default_classes.c -o Zend/zend_default_classes.lo
        /bin/sh /tempdata/php5.2-200612121330/libtool --silent --preserve-dup-deps --mode=compile cc  -IZend/ -I/tempdata/php5.2-200612121330/Zend/ -DPHP_ATOM_INC -I/tempdata/php5.2-200612121330/include -I/tempdata/php5.2-200612121330/main -I/tempdata/php5.2-200612121330 -I/opt/freeware/include/libxml2 -I/tempdata/php5.2-200612121330/ext/date/lib -I/dba/app/oracle/102/rdbms/public -I/dba/app/oracle/102/rdbms/demo -I/dba/app/oracle/102/plsql/public -I/tempdata/php5.2-200612121330/TSRM -I/tempdata/php5.2-200612121330/Zend    -I/usr/include -g  -c /tempdata/php5.2-200612121330/Zend/zend_execute.c -o Zend/zend_execute.lo
        /bin/sh /tempdata/php5.2-200612121330/libtool --silent --preserve-dup-deps --mode=compile cc  -Isapi/cgi/ -I/tempdata/php5.2-200612121330/sapi/cgi/ -DPHP_ATOM_INC -I/tempdata/php5.2-200612121330/include -I/tempdata/php5.2-200612121330/main -I/tempdata/php5.2-200612121330 -I/opt/freeware/include/libxml2 -I/tempdata/php5.2-200612121330/ext/date/lib -I/dba/app/oracle/102/rdbms/public -I/dba/app/oracle/102/rdbms/demo -I/dba/app/oracle/102/plsql/public -I/tempdata/php5.2-200612121330/TSRM -I/tempdata/php5.2-200612121330/Zend    -I/usr/include -g  -c /tempdata/php5.2-200612121330/sapi/cgi/cgi_main.c -o sapi/cgi/cgi_main.lo
        /bin/sh /tempdata/php5.2-200612121330/libtool --silent --preserve-dup-deps --mode=compile cc  -Isapi/cgi/ -I/tempdata/php5.2-200612121330/sapi/cgi/ -DPHP_ATOM_INC -I/tempdata/php5.2-200612121330/include -I/tempdata/php5.2-200612121330/main -I/tempdata/php5.2-200612121330 -I/opt/freeware/include/libxml2 -I/tempdata/php5.2-200612121330/ext/date/lib -I/dba/app/oracle/102/rdbms/public -I/dba/app/oracle/102/rdbms/demo -I/dba/app/oracle/102/plsql/public -I/tempdata/php5.2-200612121330/TSRM -I/tempdata/php5.2-200612121330/Zend    -I/usr/include -g  -c /tempdata/php5.2-200612121330/sapi/cgi/getopt.c -o sapi/cgi/getopt.lo
        /bin/sh /tempdata/php5.2-200612121330/libtool --silent --preserve-dup-deps --mode=compile cc  -Imain/ -I/tempdata/php5.2-200612121330/main/ -DPHP_ATOM_INC -I/tempdata/php5.2-200612121330/include -I/tempdata/php5.2-200612121330/main -I/tempdata/php5.2-200612121330 -I/opt/freeware/include/libxml2 -I/tempdata/php5.2-200612121330/ext/date/lib -I/dba/app/oracle/102/rdbms/public -I/dba/app/oracle/102/rdbms/demo -I/dba/app/oracle/102/plsql/public -I/tempdata/php5.2-200612121330/TSRM -I/tempdata/php5.2-200612121330/Zend    -I/usr/include -g  -c main/internal_functions.c -o main/internal_functions.lo
        echo '\
\
        /bin/sh /tempdata/php5.2-200612121330/libtool --silent --preserve-dup-deps --mode=compile cc  -Iext/oci8/ -I/tempdata/php5.2-200612121330/ext/oci8/ -DPHP_ATOM_INC -I/tempdata/php5.2-200612121330/include -I/tempdata/php5.2-200612121330/main -I/tempdata/php5.2-200612121330 -I/opt/freeware/include/libxml2 -I/tempdata/php5.2-200612121330/ext/date/lib -I/dba/app/oracle/102/rdbms/public -I/dba/app/oracle/102/rdbms/demo -I/dba/app/oracle/102/plsql/public -I/tempdata/php5.2-200612121330/TSRM -I/tempdata/php5.2-200612121330/Zend    -I/usr/include -g   -c /tempdata/php5.2-200612121330/ext/oci8/oci8.c -o ext/oci8/oci8.lo
In file included from /tempdata/php5.2-200612121330/ext/oci8/oci8.c:50:
/tempdata/php5.2-200612121330/ext/oci8/php_oci8_int.h:343: error: parse error before 'oraub8'
/tempdata/php5.2-200612121330/ext/oci8/oci8.c: In function 'php_oci_init_global_handles':
/tempdata/php5.2-200612121330/ext/oci8/oci8.c:434: warning: pointer targets in passing argument 1 of 'strlen' differ in signedness
/tempdata/php5.2-200612121330/ext/oci8/oci8.c: In function 'php_oci_fetch_errmsg':
/tempdata/php5.2-200612121330/ext/oci8/oci8.c:916: warning: pointer targets in passing argument 1 of 'strlen' differ in signedness
/tempdata/php5.2-200612121330/ext/oci8/oci8.c:923: warning: pointer targets in passing argument 1 of '_estrndup' differ in signedness
/tempdata/php5.2-200612121330/ext/oci8/oci8.c:923: warning: pointer targets in assignment differ in signedness
/tempdata/php5.2-200612121330/ext/oci8/oci8.c: In function 'php_oci_do_connect_ex':
/tempdata/php5.2-200612121330/ext/oci8/oci8.c:1035: warning: pointer targets in passing argument 2 of 'OCINlsCharSetNameToId' differ in signedness
make: The error code from the last command is 1.


Stop.
root@lrp-vks01:/tempdata/php5.2-200612121330#
 [2006-12-13 11:01 UTC] tony2001@php.net
>error: parse error before 'oraub8'

See bug #39178.
 [2006-12-13 13:18 UTC] michael dot kurz at lrp dot de
configure + make without error but make install fails!



        /bin/sh /tempdata/php5.2-200612121330/libtool --silent --preserve-dup-deps --mode=compile cc  -Isapi/cli/ -I/tem                  pdata/php5.2-200612121330/sapi/cli/ -DPHP_ATOM_INC -I/tempdata/php5.2-200612121330/include -I/tempdata/php5.2-2006121213                  30/main -I/tempdata/php5.2-200612121330 -I/opt/freeware/include/libxml2 -I/tempdata/php5.2-200612121330/ext/date/lib -I/                  tempdata/php5.2-200612121330/TSRM -I/tempdata/php5.2-200612121330/Zend    -I/usr/include -g  -c /tempdata/php5.2-2006121                  21330/sapi/cli/getopt.c -o sapi/cli/getopt.lo
        /bin/sh /tempdata/php5.2-200612121330/libtool --silent --preserve-dup-deps --mode=compile cc  -Imain/ -I/tempdat                  a/php5.2-200612121330/main/ -DPHP_ATOM_INC -I/tempdata/php5.2-200612121330/include -I/tempdata/php5.2-200612121330/main                   -I/tempdata/php5.2-200612121330 -I/opt/freeware/include/libxml2 -I/tempdata/php5.2-200612121330/ext/date/lib -I/tempdata                  /php5.2-200612121330/TSRM -I/tempdata/php5.2-200612121330/Zend    -I/usr/include -g  -c main/internal_functions_cli.c -o                   main/internal_functions_cli.lo
        echo '\
\

Build complete.
(It is safe to ignore warnings about tempnam and tmpnam).

root@lrp-vks01:/tempdata/php5.2-200612121330# make install
        echo '\
\
        echo '\
\
Installing PHP SAPI module:       cgi
Installing PHP CGI into: /usr/local/bin/
cp: sapi/cgi/php: No such file or directory
make: The error code from the last command is 1.


Stop.
root@lrp-vks01:/tempdata/php5.2-200612121330#
 [2006-12-13 13:29 UTC] tony2001@php.net
What is the ./configure line you used?

 [2006-12-13 13:41 UTC] michael dot kurz at lrp dot de
./configure --with-oci8-instant-client=/usr/local/oracle/instantclient --with-oracle=/dba/app/oracle/102 --with-sig-child
 [2006-12-13 13:51 UTC] tony2001@php.net
make clean && ./config.nice && make
 [2006-12-13 14:05 UTC] michael dot kurz at lrp dot de
/bin/sh /tempdata/php5.2-200612121330/libtool --silent --preserve-dup-deps --mode=compile cc  -Isapi/cli/ -I/tempdata/php5.2-200612121330/sapi/cli/ -DPHP_ATOM_INC -I/tempdata/php5.2-200612121330/include -I/tempdata/php5.2-200612121330/main -I/tempdata/php5.2-200612121330 -I/opt/freeware/include/libxml2 -I/tempdata/php5.2-200612121330/ext/date/lib -I/tempdata/php5.2-200612121330/TSRM -I/tempdata/php5.2-200612121330/Zend    -I/usr/include -g  -c /tempdata/php5.2-200612121330/sapi/cli/php_cli.c -o sapi/cli/php_cli.lo
        /bin/sh /tempdata/php5.2-200612121330/libtool --silent --preserve-dup-deps --mode=compile cc  -Isapi/cli/ -I/tempdata/php5.2-200612121330/sapi/cli/ -DPHP_ATOM_INC -I/tempdata/php5.2-200612121330/include -I/tempdata/php5.2-200612121330/main -I/tempdata/php5.2-200612121330 -I/opt/freeware/include/libxml2 -I/tempdata/php5.2-200612121330/ext/date/lib -I/tempdata/php5.2-200612121330/TSRM -I/tempdata/php5.2-200612121330/Zend    -I/usr/include -g  -c /tempdata/php5.2-200612121330/sapi/cli/php_cli_readline.c -o sapi/cli/php_cli_readline.lo
        /bin/sh /tempdata/php5.2-200612121330/libtool --silent --preserve-dup-deps --mode=compile cc  -Isapi/cli/ -I/tempdata/php5.2-200612121330/sapi/cli/ -DPHP_ATOM_INC -I/tempdata/php5.2-200612121330/include -I/tempdata/php5.2-200612121330/main -I/tempdata/php5.2-200612121330 -I/opt/freeware/include/libxml2 -I/tempdata/php5.2-200612121330/ext/date/lib -I/tempdata/php5.2-200612121330/TSRM -I/tempdata/php5.2-200612121330/Zend    -I/usr/include -g  -c /tempdata/php5.2-200612121330/sapi/cli/getopt.c -o sapi/cli/getopt.lo
        /bin/sh /tempdata/php5.2-200612121330/libtool --silent --preserve-dup-deps --mode=compile cc  -Imain/ -I/tempdata/php5.2-200612121330/main/ -DPHP_ATOM_INC -I/tempdata/php5.2-200612121330/include -I/tempdata/php5.2-200612121330/main -I/tempdata/php5.2-200612121330 -I/opt/freeware/include/libxml2 -I/tempdata/php5.2-200612121330/ext/date/lib -I/tempdata/php5.2-200612121330/TSRM -I/tempdata/php5.2-200612121330/Zend    -I/usr/include -g  -c main/internal_functions_cli.c -o main/internal_functions_cli.lo
        echo '\
\

Build complete.
(It is safe to ignore warnings about tempnam and tmpnam).

root@lrp-vks01:/tempdata/php5.2-200612121330# make install
        echo '\
\
        echo '\
\
Installing PHP SAPI module:       cgi
Installing PHP CGI into: /usr/local/bin/
cp: sapi/cgi/php: No such file or directory
make: The error code from the last command is 1.


Stop.
 [2006-12-13 14:15 UTC] tony2001@php.net
I don't think I can help you as long as I don't see what has gone wrong there.
It works fine here on AIX 5.1 and 5.3.
Try to look for any warnings from the linker or the compiler.

 [2006-12-13 14:30 UTC] michael dot kurz at lrp dot de
cause the copyjob for php crashes (php is missing),
I created it:

touch /tempdata/php5.2-200612121330/sapi/cgi/php

after this the install returns without error.
But php --version returns empty.
php-config --version ==> 5.2.1-dev
 [2006-12-13 15:13 UTC] tony2001@php.net
Try to look for any warnings from the linker or the &#1089;ompiler.
 [2006-12-15 09:10 UTC] michael dot kurz at lrp dot de
used gcc and gmake instead of cc and make and now completed without anymore errors.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sat Apr 19 01:01:59 2014 UTC