php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39178 Trying to install PHP 5.2 with oci8 support (Oracle10G)
Submitted: 2006-10-17 17:28 UTC Modified: 2006-10-17 17:31 UTC
From: sinu_chinthala at hotmail dot com Assigned:
Status: Not a bug Package: *Compile Issues
PHP Version: 5.2.0RC5 OS: HP Unix 11
Private report: No CVE-ID:
 [2006-10-17 17:28 UTC] sinu_chinthala at hotmail dot com
Description:
------------
I tried to compile both PHP 5.1 and 5.2 (latest from cvs) with oci8 support but make failed.

Below is what I tried for configure

#./configure --with-oci8=shared,instantclient,/opt/oracle/STAGE10G/lib


Note: /opt/oracle/STAGE10G/lib contains oracle instant client basic and sdk libararies

#make
....
....
D_XOPEN_SOURCE_EXTENDED  -I/usr/local/include -g -O2   -c /home/sra01/php5.2-200610080230/ext/oci8/oci8.c -o ext/oci8/oci8.lo
In file included from /home/sra01/php5.2-200610080230/ext/oci8/oci8.c:50:
/home/sra01/php5.2-200610080230/ext/oci8/php_oci8_int.h:343: error: expected declaration specifiers or '...' before 'oraub8'
/home/sra01/php5.2-200610080230/ext/oci8/php_oci8_int.h:343: error: expected declaration specifiers or '...' before 'oraub8'
*** Error exit code 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-10-17 17:31 UTC] tony2001@php.net
This is Oracle bug 4901517.
The most recent version of Oracle Instant Client should have this problem fixed.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sat Apr 19 06:02:27 2014 UTC