php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38511 Session module cannot store objects anymore
Submitted: 2006-08-19 13:40 UTC Modified: 2006-08-22 16:48 UTC
From: jost2345 at users dot sourceforge dot net Assigned: iliaa
Status: Closed Package: Session related
PHP Version: 5.1.5 OS: any
Private report: No CVE-ID:
 [2006-08-19 13:40 UTC] jost2345 at users dot sourceforge dot net
Description:
------------
The PHP session module needs a special hook into the evaluator so that session_write_close() can be called before the object store is cleaned. 

The session module worked in earlier PHP versions (<=5.0.4) because objects were handled differently.





Reproduce code:
---------------
A test is here:

http://php-java-bridge.cvs.sourceforge.net/php-java-bridge/php-java-bridge/tests.php5/session_write_close_bug.php?revision=1.2&view=markup

To run the test you'll need a recent JavaBridge.war deployed into a J2EE server or servlet engine and the PHP/Java Bridge classes:

http://php-java-bridge.cvs.sourceforge.net/php-java-bridge/php-java-bridge/java/README?revision=1.1&view=markup





Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-08-21 08:28 UTC] tony2001@php.net
See also bug #38473.
 [2006-08-22 16:48 UTC] iliaa@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Mon Apr 21 07:02:06 2014 UTC