php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38473 Resources destructions problem
Submitted: 2006-08-16 16:03 UTC Modified: 2006-08-22 16:47 UTC
From: pierre dot php at gmail dot com Assigned:
Status: Closed Package: Session related
PHP Version: 5CVS-2006-08-16 (snap) OS: linux
Private report: No CVE-ID:
 [2006-08-16 16:03 UTC] pierre dot php at gmail dot com
Description:
------------
You can reproduce the problem here:

http://blog.thepimp.net/misc/sessionmysql/session.php

You will get a random error (bad connection), the problem is due to the destruction of the mysql resource before the call of the session handlers.

The same code worked with 5.1 or earlier version of 5.2 (pre RC1).

Code to reproduce the problem:
http://blog.thepimp.net/misc/sessionmysql/session.php.txt
http://blog.thepimp.net/misc/sessionmysql/class.mysql.php.txt


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-08-22 16:47 UTC] iliaa@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sun Apr 20 20:02:01 2014 UTC